Can't access shared folder on VM

I've had this shared folder set up for some time on a virtualized web server (2008) so I could drop files to it from the physical server (2012) that hosts the VM

Now all of a sudden, when I try to \\hostname\foldername from the physical box, it tells me that windows cannot access it. I get prompted for credentials, I input the credentials as domain\username (also tried username@domain), and it says cannot access. Troubleshooter says I do not have proper permissions.  I double checked the permissions on the share. I have full control permissions and am a member of the domain admin group.

The only thing that has changed in the last 24 hours has been my password on the domain those virtualized VMs sit on. So I made sure I was logged out of all of the VMs on that particular domain. Issue persists.

I tried creating a new folder on the root of the D drive of the same VM, with only me having the access, and I still get hit with the same issue.

If I log on to one of the other VMs, I can access the share on the web server with no issue. So seems like there is some issue between the physical 2012 box and the VM

However, as one last step. I tried creating a folder on another VM (specifically the DC for this domain). NO ISSUES. Could access the folder from the physical server no problem

What gives?
nflynn85Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
it would seem that that vm is using cached credentials and not authenticating with the domain controller.
Zephyr ICTCloud ArchitectCommented:
Did you try rebooting the VM having the issues? Probably have but sometimes this is the only thing helping ...
Lionel MMSmall Business IT ConsultantCommented:
two suggestions 1) delete the share and then recreate it; if possible reboot after deleting it. 2) from a command prompt type net use l: \\hostname\foldername and see what you are prompted with and the errors you may get. Before you changed the password was the username and password the same on the physical and the virtual? Is it now?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

nflynn85Author Commented:
Thanks for the replies

1) Can't reboot at this time because it's in production - need to schedule downtime to do so (and I do have a workaround)

2) Net use gives me the following - Multiple connections to a server or shared resource by the same user, using more than one user name, are not allowed. Disconnect all previous connections to the server or shared resource and try again.

3) The username does not exist on the physical server/hypervisor. It exists on the domain/dc of the virtualized environment. That PW expired, and this issue has been occurring since then. I was prompted to update my PW on that domain as it had expired.
Lionel MMSmall Business IT ConsultantCommented:
this is when you try to connect using two different usernames and passwords--they have to be the same--you can test this by disconnecting all the network connections and then connecting the one that you can't connect now.
SteveCommented:
firstly, always start by checking the event viewer as the errors/warnings in there often help diagnose an issue.

Look for anything netlogon, domain or group policy related to confirm if the VM is having trouble communicating with the DC as it does appear it may not be aware of your new password.

alternatively, the netlogon message you get suggests you have an old connection still active. you must disconnect/remove it before trying to connect a new one to the same server when there is a change in credentials.

type 'net use' to get a list of existing connections.
nflynn85Author Commented:
net use on the hypervisor gave me a \\hostname\ICS$ (wasn't even sure what that ICS$ was)

I went ahead and did a type NET USE <\\hostname\sharename> /DELETE and then tried it again and that resolved it

Thanks for getting me to the solution!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.