XAMPP

When I enter - localhost:8012/ , I open to the xampp page, but when I enter the location of the database - "homes", I receive error 404.
I changed the port  80 to 8012,
DrEddieSAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dimajCommented:
How does your configuration look? Did you specify where homes could be found?
0
DrEddieSAuthor Commented:
Is this what you mean?

 The name of the database for WordPress */
define('DB_NAME', 'homes');

/** MySQL database username */
define('DB_USER', 'root');

/** MySQL database password */
define('DB_PASSWORD', 'password_here');

/** MySQL hostname */
define('DB_HOST', 'localhost');

/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8');

/** The Database C
0
dimajCommented:
So, it seems like these are your configurations of your wordpress instance. Now your apache configuration on how you can access your wordpress instance.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

DrEddieSAuthor Commented:
Reinstalled xmapp, and configured wp-config.php to read:

// ** MySQL settings - You can get this info from your web host ** //
/** The name of the database for WordPress */
define('DB_NAME', 'Homes');

/** MySQL database username */
define('DB_USER', 'DrEddieS');

/** MySQL database password */
define('DB_PASSWORD', 'Homes129');

/** MySQL hostname */
define('DB_HOST', 'localhost');

/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8');

/** The Database Collate type. Don't change this if in doubt. */
define('DB_COLLATE', '');

When I enter http://localhost/wordpress/wp-admin/install.php, I receive:

Can’t select database
We were able to connect to the database server (which means your username and password is okay) but not able to select the Homes database.

Are you sure it exists?
Does the user DrEddieS have permission to use the Homes database?
On some systems the name of your database is prefixed with your username, so it would be like username_Homes. Could that be the problem?
0
dimajCommented:
Log in to your database (if you're running mysql, run: mysql -uroot -p) From database console, run command:
show databases;

Open in new window

If that database does not exist, run:
create database Homes;

Open in new window

.

Once you're certain that database exists, run:
grant all privileges on Homes to DrEddieS@'%' identified by 'Homes129';

Open in new window

Exit database console and try accessing your wordpress instance
0
DrEddieSAuthor Commented:
1. Database - Homes existed,
2. Granted all privileges on homes to DrEddieS@'%' identified by 'Homes129';
3. Exited database console
4. Stopped and Restarted xampp
5. entered http://localhost/wordpress/wp-admin/install.php

Error returned was the same:
Can’t select database
We were able to connect to the database server (which means your username and password is okay) but not able to select the Homes database.

Are you sure it exists?
Does the user DrEddieS have permission to use the Homes database?
On some systems the name of your database is prefixed with your username, so it would be like username_Homes. Could that be the problem?
0
dimajCommented:
Make sure that your database name is correct (i.e. Homes and not homes)
0
DrEddieSAuthor Commented:
The issue was with windows 7 firewall.  Turned off my Total Defense ant-virus. Then Windows firewall requested permission to allow access to Port 80. Granted access and turned anti-virus back on
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.