Remove malware and adware from a MAC OS X 10.6.8

Hello Experts, I have a MAC that has viruses and adware.  I have ran Avast and Sophos Antivirus cleaners and the Avast found and removed some items.  However when I open Safari and go to a different page than the home page I start getting pop-ups and Avast show that I have a js:ScriptPE-Inf[Trj] infection.

The process is /system/library/privateFrameworks/WebKit2.framework/WebProcess.app/Contents/MacOS/WepProcess
The file is /Users/username/Library/Caches/com.capple.Safari/Cache.db-journal

Any thoughts on how to complete clean this system?
tucktechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andy MInternal Systems ManagerCommented:
Sounds like it may be something in the internet files cache, maybe a temporary file that's being accessed.. You could try a reset in Safari to see if that cleans it out:

    Open Safari
    Click on Safari in the menubar
    Click on Reset Safari
    Make sure that Remove All Website Data is checked
    Click on Reset

If you are using Safari 8 (OS X 10.10 Yosemite) please use the instructions below:

    Open Safari
    Click on Safari in the menubar
    Select Preferences
    Click the Privacy Tab
    Select Remove All Website Data...
    Click Remove Now
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
serialbandCommented:
Also, try this:

Open Safari
Open Preferences (command ,)
Click Extensions

Next, find the extension that might be doing this and remove it or just turn off all extensions.
0
tucktechAuthor Commented:
This worked, thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.