Upgraded ESXi from 5.1 to 5.5 U2 (HP Build) - Win 2008 R2 VM lost NIC driver

We upgraded our ESXi 5.1 to 5.5 U2 now a Windows 2008 R2 VM has no NIC driver installed.

We've checked under C:\program files\vmware tools\driver to find it for re-install but it's not there.

We also checked under c:\program files\common files\vmware tools\driver.

We upgraded the Virtual hardware of the VM from 8 to 9 (if we went to 10 I believe we can no longer use the VSphere client to manage the VM's and have to use a web interface?) using the CLI command.

Q - Do we need to upgrade the virtual HW to v10 for the NIC to start working, we have other working VM's running v9 on this host.

Vm was removed from the inventory list and re-added.

We have tried to install the latest VMWare Tools but it just sits at installing for hours. Same result if we try and remove the current VMWare Tools. Odd thing is the server is responsing quickly when navigating and opening programs etc.
Vm-No-NIC.png
VmWareTools-Slow.png
Drivers-we-see-on-C-Drive.png
ProtecITAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
No, you do not need to upgrade to v10, to get the nic driver back, something has broken your VM, no changes you have occurred by changing the Hypervisor version.

Make sure the latest version of VMware Tools is installed, and remove any network interface, and add the VMXNET3 interface.

(if we went to 10 I believe we can no longer use the VSphere client to manage the VM's and have to use a web interface?

this has now been correct, the latest vSphere Client can edit virtual machine version 10 machines, but cannot add or manage any virtual machine version 10 features.

to be honest and frank unless you need new v9 or v10 features, I would not change the version 8.0!
0
ProtecITAuthor Commented:
Thanks Andrew.

You can move around the VM but changing things like "msconfig" startups etc just goes to "not responding"

We've shut the VM down, removed the VM. Booted, shutdown. Now when we go to add a new NIC to the VM (via right click VM "edit settings" we get the following options. Should be pick VMEXNET3 ??
VM-Network-Options.png
0
ProtecITAuthor Commented:
Sorry I mean "We've shut the VM down, removed the NIC. Booted, shutdown.
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
VMXNET3 - yes, but make sure you have VMware Tools installed before you add this.
0
ProtecITAuthor Commented:
Ahh, the vmware tools installed are older than the ones the HOST now has available, problem is the system wont do anything when I either try and upgrade the tools (mounting the ISO via vSphere) or removing the current VMWare Tools via Control Panel \ Programs.....stuck :(
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
It should not make any different, if the tools are older, as long as they are present.
0
gheistCommented:
Can you show settings dialog selecting NIC?
0
ProtecITAuthor Commented:
Here's a couple of screen caps.

Opening "Network and sharing Center" just shows a completely blank page.
VMTools-HW-Cap.png
NIC-Settings.jpg
0
ProtecITAuthor Commented:
It's been sitting at the "VMTools-HW-Cap.png" screen shot for over 72 hours!
0
ProtecITAuthor Commented:
The "Safely remove hardware" screen showing SAS controller a concern?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
Power OFF VM.

Uninstall VMware Tools.

Do you have a backup of the VM ?
0
gheistCommented:
Power off VM
Change network adapter to e1000 (keeping MAC)
Power on VM
Uninstall vm tools, reboot
Install vm tools, during reboot connect vmxnet3

ESXi 5.1 supported vmxnet2 which ESXi 5.5 does not. It could be as simple as swapping adapters even on running machine (No MAC preserved then)
0
ProtecITAuthor Commented:
Power OFF VM.
Doing now.

Uninstall VMware Tools.
How do I uninstall the tools when the VM is off?

Do you have a backup of the VM ?
Yes, on another ESX host.
0
gheistCommented:
Wait - you have e1000 adapter and it is completely unaffected by any VM tools, and driver is always present in any potential guest OS released in last 10 years.
Your system is broken (as windows) without any relation to vmware.
You can try to find e1000 driver bu browsing to C:\Windows\INF\ with hardware update wizard
0
compdigit44Commented:
Have you tried to reboot the Windows VM using "Last Known Good Config"?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.