netapp fas3040 filer wont boot after disk shelfs are disconnected

Hi,

We bought 2 netapp fas3040 filers with data ontap 8.0 and some disk shelfs from an auction for testing purposes. They are tested on the site where the were and are functioning.

We now want to boot up 1 of them without the disk shelfs. So that we can retrieve the license keys it has configured in it and so that we can do a facory reset afterwards.

The problem is that we cannot get into the operating system so we can run the command "license show". We can only get in maintenance. In maintenance mode there is nog command to show the license keys.

When we try to boot normally, these are the errors that occur:

Fri Jul  3 14:44:37 GMT [fci.config.offline:info]: Fibre channel adapter 0c is offline because it is in the (unconfigured) state.
Fri Jul  3 14:44:37 GMT [fci.adapter.offlining:info]: Offlining Fibre Channel adapter 0c.
Fri Jul  3 14:44:37 GMT [fci.adapter.offline:info]: Fibre Channel adapter 0c is now offline.
Fri Jul  3 14:44:37 GMT [fci.config.offline:info]: Fibre channel adapter 0a is offline because it is in the (unconfigured) state.
Fri Jul  3 14:44:37 GMT [fci.adapter.offlining:info]: Offlining Fibre Channel adapter 0a.
Fri Jul  3 14:44:37 GMT [fci.adapter.offline:info]: Fibre Channel adapter 0a is now offline.
Fri Jul  3 14:44:44 GMT [diskown.isEnabled:info]: software ownership has been enabled for this system
arp_rtrequest: bad gateway 127.0.20.1 (!AF_LINK)
add host 127.0.10.1: gateway 127.0.20.1
Fri Jul  3 14:44:45 GMT [netif.linkDown:info]: Ethernet e0d: Link down, check cable.
Fri Jul  3 14:44:45 GMT [netif.linkDown:info]: Ethernet e0c: Link down, check cable.
Fri Jul  3 14:44:45 GMT [netif.linkDown:info]: Ethernet e0b: Link down, check cable.
Fri Jul  3 14:44:45 GMT [netif.linkDown:info]: Ethernet e0a: Link down, check cable.
1


Fri Jul  3 14:44:47 GMT [fmmb.instStat.change:info]: no mailbox instance on local side.
Fri Jul  3 14:44:47 GMT [fmmb.instStat.change:info]: no mailbox instance on partner side.
Fri Jul  3 14:44:47 GMT [cf.fm.noMBDisksOrIc:warning]: Could not find the local mailbox disks. Could not determine the firmware state of the partner through the HA interconnect.
WARNING: 0 disks found!

Storage Adapters found:
2 Fibre Channel Storage Adapters found!
0 SAS Adapters found!
0 Parallel SCSI Storage Adapters found!
0 ATA Adapters found!

Target Adapters found:
2 Fibre Channel Target Adapters found!
2 iSCSI Target Adapters found!
1 Unknown Target Adapters found!

Check that disks have been assigned ownership to this system (ID 118053397) using the 'disk show' and 'disk assign'
commands from maintenace mode.
Uptime: 20m52s
System rebooting...


Any help is appreciated.

Thanks
PramoITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PramoITAuthor Commented:
Here is another one, the above messages are stating dat the fiber channel 0a en 0c are in an unconfigured state, which can be ignored. We changed that to test if it would make some difference. Here's everyting from trying to boot to the reboot of the filer:

Phoenix TrustedCore(tm) Server
Copyright 1985-2004 Phoenix Technologies Ltd.
All Rights Reserved
BIOS version: 2.5.0
Portions Copyright (c) 2006-2009 NetApp All Rights Reserved
CPU= AMD Opteron(tm) Processor 250 X 2
Testing RAM
512MB RAM tested
4096MB RAM installed
Fixed Disk 0: STEC    NACF1GM1U-B11




Boot Loader version 1.8
Copyright (C) 2000-2003 Broadcom Corporation.
Portions Copyright (C) 2002-2009 NetApp

CPU Type: AMD Opteron(tm) Processor 250
LOADER> autoboot
Loading x86_64/freebsd/image1/kernel:....0x100000/3401704 0x53e800/3229520 0x852f50/1236008 Entry at 0x80148af0
Loading x86_64/freebsd/image1/platform.ko:.0x981000/569724 0xab5548/535632 0xa0c180/17256 0xb38198/29808 0xa104e8/1360 0xb3f608/4080 0xa10a38/54296 0xa1de50/71051 0xa2f3e0/1504 0xb405f8/4512 0xa2f9c0/256 0xb41798/768 0xa2fac0/968 0xb41a98/2904 0xa2fe88/112 0xb425f0/336 0xa2ff00/137120 0xb42740/142200 0xa516a0/425 0xa76c60/8377 0xab5456/237 0xa78d20/126216 0xa97a28/121390
Starting program at 0x80148af0
NetApp Data ONTAP 8.0.2P7 7-Mode
Copyright (C) 1992-2011 NetApp.
All rights reserved.
*******************************
*                             *
* Press Ctrl-C for Boot Menu. *
*                             *
*******************************


WARNING:  The battery is unfit to retain data during a power
          outage.  This is likely because the battery is
          discharged but could be due to other temporary
          conditions.
          When the battery is ready, the boot process will
          complete and services will be engaged.
          To override this delay, press 'c' followed by 'Enter'
c

CAUTION: Using this appliance without NVRAM
         battery backup coupled with a power
         failure condition CAN CAUSE DATA LOSS.
Are you sure you want to continue (y or n)? y
Delay for charging canceled by user. Charger is ON
Fri Jul  3 15:12:44 GMT [fci.initialization.failed:error]: Initialization failed on Fibre Channel adapter 0c.
Fri Jul  3 15:12:44 GMT [fci.initialization.failed:error]: Initialization failed on Fibre Channel adapter 0a.
Fri Jul  3 15:12:50 GMT [diskown.isEnabled:info]: software ownership has been enabled for this system
Fri Jul  3 15:12:50 GMT [config.noPartnerDisks:CRITICAL]: No disks were detected for the partner; this node will be unable to takeover correctly
Fri Jul  3 15:12:50 GMT [callhome.dsk.config:warning]: Call home for DISK CONFIGURATION ERROR
arp_rtrequest: bad gateway 127.0.20.1 (!AF_LINK)
add host 127.0.10.1: gateway 127.0.20.1
Fri Jul  3 15:12:52 GMT [netif.linkDown:info]: Ethernet e0d: Link down, check cable.
Fri Jul  3 15:12:52 GMT [netif.linkDown:info]: Ethernet e0c: Link down, check cable.
Fri Jul  3 15:12:52 GMT [netif.linkDown:info]: Ethernet e0b: Link down, check cable.
Fri Jul  3 15:12:52 GMT [netif.linkDown:info]: Ethernet e0a: Link down, check cable.
Fri Jul  3 15:12:53 GMT [fmmb.instStat.change:info]: no mailbox instance on local side.
Fri Jul  3 15:12:53 GMT [fmmb.instStat.change:info]: no mailbox instance on partner side.
Fri Jul  3 15:12:53 GMT [cf.fm.noMBDisksOrIc:warning]: Could not find the local mailbox disks. Could not determine the firmware state of the partner through the HA interconnect.
WARNING: 0 disks found!

Storage Adapters found:
2 Fibre Channel Storage Adapters found!
0 SAS Adapters found!
0 Parallel SCSI Storage Adapters found!
0 ATA Adapters found!

Target Adapters found:
2 Fibre Channel Target Adapters found!
2 iSCSI Target Adapters found!
1 Unknown Target Adapters found!

Check that disks have been assigned ownership to this system (ID 118053397) using the 'disk show' and 'disk assign'
commands from maintenace mode.
Uptime: 1m53s
System rebooting...
0
Zephyr ICTCloud ArchitectCommented:
Check that disks have been assigned ownership to this system

I think one gets this message when the disks are assigned to the other controller ... I've seen something similar on a Netapp system once, it got stuck in a boot-loop because of it.
0
PramoITAuthor Commented:
But I dont want to assign disks. I want to get in the OS.

Can I do something in the maintenance mode to avoid this reboot loop?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Zephyr ICTCloud ArchitectCommented:
You could try with reassigning disks, make them "unowned"

Something like this maybe: "disk assign <disk_id> -o unowned"

That can be done in maintenance mode.

You can first check the sysid owner with "disk show"
0
PramoITAuthor Commented:
Hi,

It's not possible to assign disks, because it doesn't see any disk.

*> disk_list
     DISK    CHAN  VENDOR   PRODUCT ID       REV  SERIAL#              HW (BLOCKS   BPS) DQ
------------ ----- -------- ---------------- ---- -------------------- -- -------------- --

No disks found on system!  Check cabling,
SCSI id jumpers and drive termination.

Regards,
0
PramoITAuthor Commented:
Here's the result of the command disk show

*> disk show
Local System ID: 118053397

disk show: No disks match option show.
0
Zephyr ICTCloud ArchitectCommented:
I'm afraid you'll need to attach some disks (shelves) to get things going ... Wish I could test this myself but I have no access to a separate controller ...
0
PramoITAuthor Commented:
Even when i connected a disk shelf and assigned disk to the filer it didn't boot to the OS.

I've managed to get the license through the former owner. So i have reset both filers and have configured them. Thanks for the help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Zephyr ICTCloud ArchitectCommented:
Ok, sounds like the best solution indeed ... Thanks for the follow up!
0
PramoITAuthor Commented:
Seems like the filers can't be started if the original config isn't present anymore. So a reset was the only option for us.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.