How to set new exchange mail database as the default?

We had a customer call us after they messed up their exchange database to the point where we recommended just creating a new mail store. I did that, removed a mailbox associated with the previous mail database and then re-added it to the new one. OWA is working fine, however when I attempt to create a new profile in outlook, it doesnt auto populate the information like it normally does.

If I manually enter the information, it doesnt work.

2 questions:
1 - what do I have to do to get outlook functional?
2 - How can i fix outlook so it auto populates the users name, and email address when creating a new profile?
skyadminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
Did you decommission the Exchange server that is holding multiple roles i.e. CAS/HUB/MBX?

The process of connecting to a users mailbox is done via Autodiscover which is configured on the CAS server. If you simply created a new database and moved the mailboxes over to the new database Autodiscover should not have been changed which would mean the mailbox would connect again after re-starting Outlook.

If you open the users mailbox in Outlook do the following...
- hold ctrl+right click the Outlook icon in the system tray
- select Test-Email Auto Config
- run the autodiscover test
- check what your autodiscover URL is and then make sure that it is the same as what you have on the CAS server

WIll.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Amit KumarCommented:
I think you have not set RpcClientAccessServer property of new created Database:

Please check by below command.

Get-MailboxDatabase database_name | fl Name, RpcClientAccessServer

if above command results blank so please run below one

Get-MailboxDatabase database_name | Set-MailboxDatabase -RpcClientAccessServer <your client access array name>
0
AmitIT ArchitectCommented:
@AKG,

You don't need to set it for every new DB. It will be set for new DB automatically.

@skyadmin

Your suggestion of creating new DB was not the right solution. You could have created a dial-tone db and everything would have been back to normal. Only data need to be restore, which you can restore from backup, if customer was taking.

Let's come back to your issue, do you see any .prf file on user machine under office installation path, can you share it. If not present, then I will first ask you to check with OWA and share the result.
0
skyadminAuthor Commented:
This client had no backups to restore any data from. They only had some .ost files. I was able to connect to each box and export their mail to a .pst file.

The issue was actually because none of the computers are actually domain joined. We seem to have picked up kind of a nightmare here. Was able to get it working by using outlook proxy settings to point to the server.

Thanks for all your input.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.