Hard Drive Resized in Disk Management, But Not Windows Explorer

Points of My Scenario:
1. I have a Windows Server 2003 computer with multiple disk volumes from SAN storage
2. I successfully added storage to one of the volumes and extended the drive using "diskpart"
3. Disk Management (diskmgmt.msc) shows the new size successfully in the bottom pane
4. Windows Explorer shows the original smaller size - even after rebooting the server
5. The Extpart.exe utility returns the error "unable to get partition information for current volume"

QUESTION: What can I do to make Windows Explorer show the new drive size?
waltforbesSenior IT SpecialistAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Tony GiangrecoCommented:
Try Extpart in safe mode. The paging file may be locked of something else in is contention on that drive.
waltforbesSenior IT SpecialistAuthor Commented:
Will Windows be able to see SAN volumes while in Safe Mode?
Tony GiangrecoCommented:
I don't know. I never tried it.
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

Tony GiangrecoCommented:
Possibly log into the san device and try it there.
waltforbesSenior IT SpecialistAuthor Commented:
Hi TG-TIS: Unfortunately, neither Windows Explorer nor Extpart could read the SAN-based drives while in Safe Mode.

In regards to logging onto the SAN, note that the SAN utilities are able to see the extended drive space already. Even disk management can see it: only Windows Explorer is unable to see it. It must be an OS-level issue.

Thanks so much for the ideas. I'll keep researching.

Kind regards,
Walt
Tony GiangrecoCommented:
What size did you expand the drive to? Windows 2003 generally won't see anything past 2TB.  That's an OS and BIOS limit on most older hardware.

Take a look at these for more info:

https://support.microsoft.com/en-us/kb/2581408

http://blogs.technet.com/b/askcore/archive/2010/02/18/understanding-the-2-tb-limit-in-windows-storage.aspx

http://arstechnica.com/civis/viewtopic.php?f=17&t=472424

Hope this helps!
rindiCommented:
Shrink the disk by about 10MB. Sometimes when you expand a partition the full amount you won't see the actual size from explorer etc., but if you leave about 10MB unformatted it will show the correct size.
waltforbesSenior IT SpecialistAuthor Commented:
@TG-TIS: I am extending the volume from a mere 60 GB (sixty gigabytes) to 80 GB (eighty gigabytes)

@rindi: I could not find a way to shrink the disk on Windows Server 2003. Eventhough Microsoft has an article about how to do it with Diskpart.exe (Diskpart: https://technet.microsoft.com/en-us/library/cc766465(v=ws.10).aspx), the shrink option is not available (as other sites have also reported)
Tony GiangrecoCommented:
Have you tried accessing the San from another server or PC to verify the size?
rindiCommented:
Check if you can shrink it directly from within diskmanagement. On newer OS's that is available there.

One further thing, you should realize is that your OS is very old, and support for it is ending this month (the 14th if I'm not mistaken). After that you won't get any patches anymore and it's vulnerability will increase. You should really replace it asap. That would also make your current issue unimportant.
waltforbesSenior IT SpecialistAuthor Commented:
@rindi: Windows Server 2003 doesn't natively support shrink from within diskmanagement. Yes: it's true! July 14th is 'my' deadline to get rid of these boxes!

@everyone: I found the solution! You won't believe it: I ran diskpart again and selected the problem volume (select volume x). Finally, I just typed "extend" and pressed Enter! I didn't specify a size, just typed that single one word "Extend"!

And guess what: I didn't even mean to press Enter! I was planning to re-do the foll command "Extend size=20480"! Thanks, God! :-)

Thank you all for your attention and willingness!

Kind regards,
Walt

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
andyalderSaggar maker's framemakerCommented:
It's a standard problem, "extend filesystem" is the correct syntax although I guess just "extend" might work.
https://support.microsoft.com/en-us/kb/832316 (ignore the hotfix info and skip down to the more information section. BTW, not restricted to Win2003, seen it with 2008R2 as well.
waltforbesSenior IT SpecialistAuthor Commented:
I solved my own problem! I have explained the solution in my last comment - which I have accepted.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.