.net backwards compatibility

Hi all,

I have a software company requesting we install multiple versions of .NET on client machines would the latest version 4.5.x not include all the functionality of .NET v3.5 and below as well? Or will this need individual installs of each version .NET?

Many thanks in advance.

Kind regards
SolidsoundAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AndyAinscowFreelance programmer / ConsultantCommented:
You should just need to install the latest which would contain support for previous versions.
0
JohnBusiness Consultant (Owner)Commented:
I keep .NET Framework V3.5 and all its updates and V4.5 and all its updates. Those two versions are available to be enabled in Windows Features (in Programs and Features).

I do this myself and for clients and it seems to cover all the requirements.
0
Jacques Bourgeois (James Burger)PresidentCommented:
If you plan to recompile the old applications on framework 4.x (which I would recommend), it contains almost all the features of 3.5. A few classes are now obsolete, but a few out of more than 10,000 is almost meaningless... unless you happen to have been using one of those that were retired. I have personally never encountered any and I have converted many applications, but some of my students encountered obsolete and non-supported older classes while trying to convert old code.

Some old 3rd party dlls also do not work well if you try to use them in 4.x projects.

If you plan to leave the applications compiled as 3.5, then you need to install both versions of the framework. The version of the Common Language Runtime (CLR) that provides the basics of the framework changed in 4.0

So, in order to run on the same computer applications compiled prior 4.0 and post 4.0 you need to install both the 3.5 framework, and a version of 4.x that is compatible with your 4.x applications.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
_TAD_Commented:
Some object types have become deprecated (obsolete) in .Net 4.5.   If your program uses these types they may no longer function as you would expect.

Obsolete Types
https://msdn.microsoft.com/en-us/library/hh419162(v=vs.110).aspx

Obsolete Members
https://msdn.microsoft.com/en-us/library/hh419161(v=vs.110).aspx



fyi.... sometime around the year 2001 Sun Microsystems changed the way Java handled 'Null' values and caused my company a lot of grief.  Backwards compatibility is not always a guarantee.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.