Link to home
Create AccountLog in
Avatar of Christian de Bellefeuille
Christian de BellefeuilleFlag for Canada

asked on

Sharing my iPhone Internet Connection with a Desktop while NIC enabled

My ISP got some problems at the moment.  So i've setuped my iPhone to Share it's Internet Connection thru USB, which work just fine as you can see.  But the problem is that i've to disable my desktop NIC to make it work, otherwise it seems to try to connect to internet thru my router which has no connection.

The problem is that i've my SQL Server on my LAN, and i need this NIC enabled.

Is there a way to specify to Windows 7 to use iPhone for Internet, and look at the masks & subnet for anything else to find which path it should use? (And how?)

Thanks
Avatar of Mike Roe
Mike Roe
Flag of United States of America image

Click on the wireless settings in the taskbar and select the iphone as the connection.

Or go into control control panel, network and sharing and find wireless adapter and add your iphone to the connections.
Avatar of Christian de Bellefeuille

ASKER

I've specified Desktop (like most desktop, there's no Wifi), plus i've specified that the iPhone is connected to it thru USB, and i've specified that it was working properly if my NIC was disabled.  I'm asking how to make it work, with this setup, but with NIC enabled.  Thanks
ASKER CERTIFIED SOLUTION
Avatar of John
John
Flag of Canada image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
SOLUTION
Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
Sorry Miss read the question about USB.  Try to change the metric on the Lan connection and see if it works
Great!  It work!  

For the benifit of others who could be looking for this, here's some additional informations:

SHOW ACTUAL METRIC
Type netstat -an from the Command Prompt.  In my case i had to look at IPv4 Route Table and see the Interface IP vs Metric

CHANGE METRIC ON WINDOWS 7
Open the Network Adapter Properties (Control Panel > Network and Internet > Network Connections > right-click on adapter and choose Properties)
Open the properties of Internet Protocol Version 4 (TCP/IPv4)
Click Advanced
Untick "Automatic Metric" and set a lower number for the connection that have an higher priority
Click OK
Thanks for the update and I am glad changing the metric worked for you.
Another note: I thought that by changing the order of the connections under the Network Connections / Advanced Settings would change that metric, "bypass" that metric, but it's not the case.  Even if i setuped the iPhone at 1st position under "Connections are listed in the order in which they are accessed by network services", it was not enough to make it work.   Metrics was the answer!

A huge thanks!