Link to home
Create AccountLog in
Avatar of AntExpert
AntExpertFlag for United States of America

asked on

Exchange 2010 the distribution group setting "require all senders are authenticated" is not working

Powershell shows "RequireSenderAuthenticationEnabled     : True" and I do not have "Externally secured" checked on any receive connectors, but I can still send to this group from the outside. I tried deleting and recreating the group, but it still accepts messages. Email comes in from a local Spam server. Any Ideas?
Avatar of Will Szymkowski
Will Szymkowski
Flag of Canada image

If you send from a legitimate email youremail@gmail.com to this group does it work? Sometimes spammers still find a way to mask the domain which allows the email to pass through. If this is strictly a spamming this you might want to take a look at your spam filter to see if there are any other logic rules you can put in place.

However, you are always going to get some sort of spam even with the best spam appliances out there.

Will.
Avatar of AntExpert

ASKER

I can send from a generic gmail account to this group yes, or any group for that matter, since the "require all senders are authenticated" does not work.
Does this happen for any group that are you using with "Require Authenticaiton Enabled True"? or just this specific group.

If this affects all groups then i would look at our Receive Connectors and make sure that the proper permission groups and authentication on the default receive connector and also any custom ones you might have as well.

If all groups are acting this way then something has changed at the org/recevie connector level.

Will.
Yes all groups seem to ignore this setting and I can't identify whats wrong with the receive connectors? Email is delivered from a local spam server, could that have something to do with it?
It is possible. Not sure why all groups would have this setting ignored. Have you tried to check the permissions on your default receive connectors? Also have you tried to re-create them?

Will.
I just connected to the Exchange server via telnet, and it does reject messages to the group and indicates that authentication is required, so based on that, it appears the server is doing what it should. It must have something to do with how the spam server is forwarding messages to Exchange. If you have any ideas on how this should be configured,  I would appreciate your input.
ASKER CERTIFIED SOLUTION
Avatar of AntExpert
AntExpert
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
I discovered that the exchange server was not the problem by using telnet.
I then began to research my Spam server and discovered the fix to the problem.