We help IT Professionals succeed at work.

Cannot log into legacy Exchange 2007 mailbox in Coexistence via Outlook 2013 with Outlook Anywhere

David Borg
David Borg asked
on
136 Views
Last Modified: 2015-11-11
I attempted to go into coexistence this last weekend but had to roll back due to not being able to connect to Exchange with Outlook 2013 externally. Everything else worked without a problem and Outlook would connect internally without a problem. OWA was able to proxy externally to the 2007 mailboxes without a problem.

I verified that the authentication setting were the same on both RPC vDirs (Exchange 20007 and 2013). I tried both Basic and NTLM for the ExternalClientAuthenticationMethod property (Basic would prompt for creds and NTLM would just not connect). IISAuthenticationMethods is set to Basic, NTLM.

Any ideas?

AD:
Server 2008 R2 level
Exchange 2013 and 2007 are in different sites
Same Forest/Domain

Exchange 2007:
2 Server 2008 R2 Exchange 2007 standard servers
Only one is configured with mailboxes, connectors, etc
No NLB as only one server is active and functional
IPv6 disabled via registry

Exchange 2013:
2 Server 2012 Exchange 2013 Standard Servers (non R2 Windows)
Microsoft IIS ARR 3.0 on server 2012 acting as proxy for primary mail namespace (mail.domain.com)
Autodiscover is set to use mail.domain.com for resolution with corresponding scp records internally
IPv6 enabled
Comment
Watch Question

Scott CSenior Engineer
CERTIFIED EXPERT

Commented:
Try doing a fiddler trace while you are reproducing the issue.

http://www.telerik.com/download/fiddler

Make sure the HTTP traffic is unencrypted.  See if you can tell where the authentication prompts are happening.

Unfortunately Outlook logging can only be used if Microsoft is involved as the .ETL logging files created can only be viewed by them with internal tools.
David BorgNetwork Administrator

Author

Commented:
I will have to try this when I can put us back into Coex.
Will SzymkowskiSenior Solution Architect
CERTIFIED EXPERT
Most Valuable Expert 2015
Top Expert 2015

Commented:
For Exchange 2013 you need to make sure that you properly NAT-ed to the 2013 CAS server on your firewall. Once you have done this then your Exchange 2013 clients should be able to access OWA without and issue.

Exchange 2007 clients will be re-directed automatically when they login to the Exchange 2013 OWA login page.

Will.
David BorgNetwork Administrator

Author

Commented:
Will,
OWA works fine and the proxy happens as it should. The problem is with Outlook Anywhere connections being proxied back.
Will SzymkowskiSenior Solution Architect
CERTIFIED EXPERT
Most Valuable Expert 2015
Top Expert 2015

Commented:
Outlook Anywhere should only be confiugred on the Exchange 2013 server. Did you have it confiugred in both places?

I would also suggest that you try using https://testconnectivity.microsoft.com/ with an account on Exchange 2013.

Also,

Run through the Exchange Deployment Assistant to make sure that all of the steps have been completed correctly.

Exchange Deployment Assistant
https://technet.microsoft.com/en-us/office/dn756393.aspx

Will.
AmitIT Architect
CERTIFIED EXPERT
Distinguished Expert 2017

Commented:
Please test with this site:
https://testconnectivity.microsoft.com/

Select Outlook connectivity test and share the result.
David BorgNetwork Administrator

Author

Commented:
It was configured on both servers as far as I could tell. I used the deployment assistant for the settings (checked and set 3 different times to make sure). I also make sure that the authentication in both locations matched precisely and the externalURL was set to mail.domain.com.


I did not use the connectivity analyzer (dumb mistake at 3am).
David BorgNetwork Administrator

Author

Commented:
I will try to run the connectivity analyzer tonight and see what the results are. I will update accordingly.
David BorgNetwork Administrator

Author

Commented:
Alright...I was able to run the connectivity analyzer last night but not fiddler (connection was flaky and I had limited time).

There was an error "Attempting to ping RPC proxy mail.domain.com". It said the remote server returned error (404) Not Found. I attempted the test with a 2013 and 2007 mailbox.

When I received this error, I attempted to browse to https://mail.domain.com/rpc/rpcproxy.dll and once logged in I received the blank web page but not a 404 error.

After doing a little research this morning, I may not have used the tool correctly. I selected to run the "Outlook Anywhere" test and entered all of the info. It is my understanding that the RPC Proxy Server name and the Exchange Server name are one in the same with Exchange 2013, correct?

Any ideas?
Will SzymkowskiSenior Solution Architect
CERTIFIED EXPERT
Most Valuable Expert 2015
Top Expert 2015

Commented:
depending on what test you are running you need to ensure that your autodiscover and mail.domain.com is correct as well. How is your current Exchange certificate configured? What DNS names do you have on your UCC cert? Do you have autodiscover setup as an SRV record on your external DNS?

Will.
David BorgNetwork Administrator

Author

Commented:
We do not have autodiscover set up externally. I entered the info manually.

The certificate is set to be used by all services and has these names (in this order):
mail.domain.com
autodiscover.domain.com
test.domain.com
legacy.domain.com

*knucklehead moment*...I did find out that the firewall was enabled on the ARR server and could not ping the IIS ARR proxy server that mail.domain.com goes through. I am disabling the firewall for now (we have to have them enabled for audit purposes) to test and will update accordingly.
Will SzymkowskiSenior Solution Architect
CERTIFIED EXPERT
Most Valuable Expert 2015
Top Expert 2015

Commented:
That is part of the NAT-ing that needs to be done for the Exchange 2013 server as i stated in my eariler post.

If it errors out again please post the exact error message.

Will.
Network Administrator
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION
David BorgNetwork Administrator

Author

Commented:
The solution was due to me missing that step.

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.