ODBC error on 64bit mahcine

Hello Experts,

I released a new build of my application and now on 64bit machines I am getting this error:


ERROR [IM014] [Microsoft][ODBC Driver Manager] The specified DSN contains an architecture mismatch between the Driver and Application

This was working fine on my last build and I didnt really change anything that has to do with the ODBC or anything like that.



        'Look for SQL Engine
        Try
            Dim str As String = "DSN=sqlbase;uid=dba;pwd=password;"
            Dim con As New OdbcConnection(str)
            Dim com As String = ("select company from sysinfo")
            Dim Adpt As New OdbcDataAdapter(com, con)
            Dim ds As New DataSet()
            Adpt.Fill(ds)
        Catch ex As Exception
            MessageBox.Show("SQL Engine not running! Closing application.  " & ex.Message, "Error", MessageBoxButtons.OK, MessageBoxIcon.Error)
            End
            Exit Sub
        End Try

Open in new window



SyBase SQL Anywhere v10
VB.net VS2010
triphenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

it_saigeDeveloperCommented:
You need to install 32-bit versions of the SyBase drivers on the 64-bit clients.

-saige-
0
triphenAuthor Commented:
Problem solved.....

I had changed the Target CPU to "Any CPU" during my last build. I changed it back to x86 and all is well.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
it_saigeDeveloperCommented:
I was just about to recommend that as well.  ;)

-saige-
0
triphenAuthor Commented:
I found my issue. It was the Target CPU setting.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.