Need help getting Canon printer working with Windows 7

I have a Toshiba Satellite laptop with Windows 7 Pro.  I have two printers that work well with it, and I also have a Canon imageclass MF 3111 that I would like to use with it as well, but I can't seem to get it working.

The drivers download section of the Canon website says:

There is no driver for the OS Version you selected. The driver may be included in your OS or you may not need a driver.

With no luck taking that route, I did some searching and came up with this:

I have luckily managed to figure out how to get my Canon MF3110 printing with Windows 7 64 bit even though there is no driver for Windows 7 64bit for the Canon MF3110 Multifunction Printer. The solution is to download the Windows 7 64 bit printer drivers for the Canon MF5750 and then install the drivers as your LPT1: Printer.  Note this same work around should work in theory with the Canon MF3111 model as well.

Nope. That didn't work for me.

So it's time to toss it you, the Experts, to see if there really is a way to get the thing cranked up and working.

How 'bout it?
RadioGeorgeOwner/ProgrammerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
I found Windows 7 drivers on the Canon site. Look on the page here and there is a pull down for various operating systems including Windows 7 and Windows 8

If you pull down Windows 7 (not Windows 7 64-bit) there is a driver. I am not sure if the Windows 7 32-bit driver will install. It may be worth trying.

http://usa.canon.com/cusa/windows_7/multifunction_printers/laser/imageclass_mf3110?selectedName=DriversAndSoftware

It is an older printer apparently, so it may not work.
William FulksSystems Analyst & WebmasterCommented:
Installing them on the LPT1 port should work, but there's another step to it!

After you install the drivers to LPT1, go into the Printer Properties and then to the Ports tab and then add a port for the IP to your printer and make sure it is checked. The printer should then work.
William FulksSystems Analyst & WebmasterCommented:
Also, as a quick workaround, if you have another computer on the same network that can print to it, you could always share the printer from that computer and then connect to it that way.
Active Protection takes the fight to cryptojacking

While there were several headline-grabbing ransomware attacks during in 2017, another big threat started appearing at the same time that didn’t get the same coverage – illicit cryptomining.

zalazarCommented:
You might have a look at this forum thread.
https://social.technet.microsoft.com/Forums/windows/en-US/3713a398-019a-409e-8d0f-29944bb60fac/canon-mf3110-printer-not-working

From the thread:
Quote/
1. Download the following driver
http://www.usa.canon.com/consumer/controller?act=ModelInfoAct&tabact=DownloadDetailTabAct&fcategoryid=335&modelid=11148
Select Windows 7 (x64) in the drop down menu
And download these drivers: MF5730_5750_MFDrivers_Win_x64_us_EN_7.exe

2. Unzip the exe

3. Make the following modifications:
a. Filename : MF5700AU.INF - Filetype Setup Information 3 KB
[Canon.NTamd64]
"Canon MF5700 Series" = MF5700,USBPRINT\CanonMF5730c609,CanonMF5730c609,"MF5730"
"Canon MF5700 Series" = MF5700,USBPRINT\CanonMF5750660a,CanonMF5750660a,"MF5750"
"Canon MF5700 Series" = MF5700,USBPRINT\CanonMF5770060b,CanonMF5770060b,"MF5770"
"Canon MF5700 Series" = MF5700,USBPRINT\CanonMF31102FE8,CanonMF31102FE8,"MF5770"

b. Filename : MF12SCN.INF - Filetype Setup Information 21 KB
[Models.NTamd64.5.1]
%LPTENUM\MF5730.DeviceDesc%=MF5730Install_XP,USB\VID_04A9&PID_265D&MI_00
%LPTENUM\MF5750.DeviceDesc%=MF5750Install_XP,USB\VID_04A9&PID_265E&MI_00
%LPTENUM\MF5770.DeviceDesc%=MF5770Install_XP,USB\VID_04A9&PID_265F&MI_00
%LPTENUM\MF5770.DeviceDesc%=MF5770Install_XP,USB\VID_04A9&PID_2660&MI_00

4. Save the .inf files

5. Plugged in the USB cable of my printer. When it did not install it properly went to the properties section. Clicked on settings and then driver update. Specified the location of the drivers mentioned above. And let windows do the rest. It did say that the drivers are not digitally signed but I went on nevertheless.

6. This installed the scanner.

7. For the printer I installed the printer driver from the same location as a new printer first and on Virtual USB port 1 as my laptop does not have an LPT or COM port.

8. Then made it the default printer and it worked.
/Quote

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RadioGeorgeOwner/ProgrammerAuthor Commented:
WOW! This solution was the only one that worked, and I am flabbergasted. It's really something when an individual comes up with a solution that basically shows up a major computer equipment manufacturer. The simple code modifications and suggestion to use USB port 1 worked on the  first shot. Now I have two solid working printers. It's irritating to see that there is a solution, but Canon simply did not make it available, for whatever reason (or lack of smarts) that they may have had. This is an excellent example of how big a value and help Experts Exchange can be!
zalazarCommented:
Very good to hear that it worked and thank you very much for the appreciation.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Printers and Scanners

From novice to tech pro — start learning today.