Need to create Group Policy Object to disable Archive from the Outlook 2010 Cleanup Tools

I have a GPO that disables auto-archive but today a staff member found that they can archive using the cleanup tools.
File-->Cleanup Tools-->Archive

I have the Administrative templates loaded but cannot find where that function can be disabled.  I have previously disabled items by creating a GPO editing a registry key.  Is that an option?

Thank you

Cleanup tools
JC2010ceAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
All you need to do is download the Office ADM Template for the version of office you are running.
Office 2010
http://www.microsoft.com/en-ca/download/details.aspx?id=18968

From there you can configure this from the following location...
User configuration\Administrative Templates\Microsoft Outlook 2010\ Outlook Options\ Other\AutoArchive

Will.
0
JC2010ceAuthor Commented:
Will,

Thanks for the comment.  I had already disabled Auto-Archive in 2014.  The GPO is enabled and successfully propagated to the domain.  This is a separate functionality in the Cleanup Tools is run ad-hoc.  I need to disable the Archive feature in the Cleanup Tools

John
0
JC2010ceAuthor Commented:
I found a 2010 document referencing using Control ID's to manage Office functionalities via GPO

https://technet.microsoft.com/it-it/library/cc179143%28v=office.14%29.aspx

And downloaded the Office Fluent User Interface Control Identifiers
http://www.microsoft.com/en-us/download/details.aspx?id=6627

After installation, I performed a search on the C:\Office 2010 Developer Resources\Documents\Office2010ControlIDs folder and found OutlookExplorerControls.xlsx contained the word archive.  

I located an entry for Archive that was marked as Control Type - Button and Tab Set and Tab - Not in the Ribbon. CTLID 1886

To the GPO I used to disable Auto-Archiving, I navigated to User Configuration\Policies\Administrative Templates\Microsoft Outlook 2010\Custom\

Opened the policy "Disable command bar buttons and menu items"  clicked Enable, clicked Show, then added Value 1886

I clicked OK, Apply, OK

I had previously added the Office 2010 Administrative templates (admx and adml)
http://www.microsoft.com/en-us/download/details.aspx?id=18968
to my C:\Windows\PolicyDefinitions folder.

I closed Outlook on my Test PC, ran Gpupdate /force and reopened Outlook.
The Archive button in Cleanup tools was disabled (greyed out)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

JC2010ceAuthor Commented:
I've requested that this question be closed as follows:

Accepted answer: 0 points for JC2010ce's comment #a40923022

for the following reason:

By using partial information from multiple sources, I was able to create a solution to the exact issue.   No one  on EE had any information for my issue.  I provided documentation on where I found supporting information and provided exact details as to how I created the group policy.
The solution I provided is unique and fully documented
0
Will SzymkowskiSenior Solution ArchitectCommented:
Glad that you found your solution.

Will.
0
JC2010ceAuthor Commented:
why am I being awarded no points on this solution?  Thanks
0
Will SzymkowskiSenior Solution ArchitectCommented:
Because it is your own quesiton. That is why. You do not get points for your own quesitons you post.

Will.
0
JC2010ceAuthor Commented:
can you please accept this as a solution as it is the correct solution and no one else came up with it
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Outlook

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.