Exchange 2010 Mails not working.

Hi,

My mails are not working. i am using sbs 2011 and configured exchange 2010. The internal mails also not working. Please  help me to fix this issue.
reejeshAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Nick RhodeIT DirectorCommented:
Check to make sure your exchange services are running.

On the SBS Server > Administrative Tools > Services

Click the Startup Type to sort the services.  Scroll through the exchange services and make sure they are all started
RantCanSr. Systems AdministratorCommented:
Please post screenshots or text from any errors you may see. SBS 2011 is a notoriously fickle beast and the experts need as much information as possible to help.
Will SzymkowskiSenior Solution ArchitectCommented:
If internal mail is not working then it is most likely the Exchange services that are not started. Also check the AppPools as well.

If all of the services are started then you will need to check your receive connectors on Exchange.

Will.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

reejeshAuthor Commented:
Thank you for the reply. All echange services are started. and i tried restarting also. We use mimecast for email filtering. I got reply from mimecast that the issue is with one of the servers which is not allowing them to deliver mails.
reejeshAuthor Commented:
I received the test mail now which i send 4 hours back.
Will SzymkowskiSenior Solution ArchitectCommented:
The because you have actually received the email means that nothing is blocking communication i.e. (Firewall). However it might be a possible routing issue or another appliance doing another level of scanning of some sort.

Will.
reejeshAuthor Commented:
Problem solved after upgrading the physical memory from 16GB to 32GB

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.