Blocking DNS IP registration of public server Win 2003/2012R2

I have a Windows 2012 server in the DMZ with an internal IP address and have unset the option to register the IP in DNS. I have assigned the server a public IP address and created an A record on our Win 2003 DNS servers and created proper routing so that everyone can hit the server with the public IP. The problem is that the internal IP keeps repopulating itself in DNS and therefore clients are attempting to connect with the internal IP from remote sites via the VPN tunnel instead of the public internet. Is there something else i need to do to stop the registration of the internal IP in DNS?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RantCanSr. Systems AdministratorCommented:
Are you using VLANs? If not, this looks like a complex enough set up, you might need them. VLAN would solve this problem by segmenting the DNS for the internal v. DMZ.  There are details on this thread:
drichmanAuthor Commented:
No, not using VLAN's in this situation, and I do not believe i need them. All I am trying to do is make the 2012 server not register its IP in DNS, which would allow my manually entered A record at the only answer upon lookup.
RantCanSr. Systems AdministratorCommented:
You should try removing it from the internal domain. If it is a windows domain member, then it will always register in DNS, because LDAP.
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

drichmanAuthor Commented:
It has to be a domain member as it is a password management portal.
RantCanSr. Systems AdministratorCommented:
Try creating a split-brain DNS for internal v. external. If clients are connecting via VPN, they will resolve internally by design, requiring this setup.  Details here on concept and configuration:

But here is the TL;DR.

Create a zone on 2k3 DNS so that responds to internal address of your server. The A record for the ISP will do the job for the internet connecting to
drichmanAuthor Commented:
I believe you are over complicating the issue. All I am looking for is to block the registration of the adapters IP address in DNS....
Dirk MareSystems Engineer (Acting IT Manager)Commented:
This is simple task to complete if you have a dual homed server (2x NIC's)
LAN 1: Public
LAN 2: Private Network
Not sure if this is the case because its not mentioned..
Go to DNS management on your DMZ server.

Right click the server name and select properties.
DNS properties
Select only the following IP address and disable the adapter on the Private (local) network.

drichmanAuthor Commented:
It appears this reg key fixed the problem that the  "unset the option to register the IP in DNS" GUI setting couldn't.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
drichmanAuthor Commented:
This solution blocked the DNS registration.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.