Outlook 2007 cannot connect to Mailbox after migrating to Exchange 2013

Greetings Experts,

I am in the phase of migrating my Exchange 2010 Server to Exchange 2013.
Some mailboxes are currently to Exch 2010 and some have been migrated to Exch 2013.

Using Outlook 2007 and for Mailboxes that now live on Exch 2013:
- I add a new E-mail Service and select the Microsoft Exchange ‘’profile”
-I enter the Exch Server 2013 IP address
-I enter the user name and when I click check (in order to find the username)
I receive the following message:
“The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action.”

Please note that following the above procedure for mailboxes that are still on Exch 2010,
the username is resolved successfully and the outlook connects to the mailbox.

Please also note that I can successfully connect to the Exch 2013 Mailboxes via OWA, IMAP and POP3.

What am I missing here?
mamelasAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MASEE Solution Guide - Technical Dept HeadCommented:
Please wait few minutes and try again.
Did you point your autodiscover and common name to Exchange 2013 IP?
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Are any mailboxes accessible on exchange 2013?

Can you confirm the mailboxes have been moved accross correctly into exchange 2013? login to the emc and check.

It sounds like the mailboxes are not moved, why would they still resolve on the 2010 server if they have been moved to 2013?
mamelasAuthor Commented:
Dear Mas,

Where should I ckeck the if the autodiscover and common name are pointed to the correct Exchange?

Could you please provide me the steps required?

Thanks in advance
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

mamelasAuthor Commented:
Dear Mark Bill,

The Mailboxes that I have chosen to be migrated are moved successfully.

The Mailboxes that can be resolved from Exch 2010, are the mailboxes
that are not migrated yet. Therefore they reside to Exch 2010.

For Mailboxes that reside to Exch 2013, can be accessed via OWA/POP and IMAP
but NOT via Outlook.
Mark BillExchange, AD, SQL, VMware, HPE, 3PAR, FUD, Anti MS Tekhnet, Pro EE, #1Commented:
Can you login to any mailbox on Exchange 2013 server?

Who did the migration?
mamelasAuthor Commented:
Dear Mark Bill,

As per my above commnet I can connect to the Mailboxes that live on Exch 2013
via OWA , Pop3 and Imap.

The Outlook 2007 can connect to these mailboxes via pop3 account but not
by selecting the Microsoft Exchange option.
mamelasAuthor Commented:
In addition to the above messages please be advised that
the Autodiscover exists to Exch 2010 and Exch 2013 as well.

Is it possible to set the default Autodiscovery Server?
(I am assume that during outlook mailbox setup the outlook
search the username using the Autodiscovery of the Old 2010 Exch)
MASEE Solution Guide - Technical Dept HeadCommented:
Did you point autodiscover.emaildomain.com to Exchange2013 IP?
If not please do change it.
Did you point your common name to Exchange 2013 IP
If not please do change it.
mamelasAuthor Commented:
Dear Mas,

The IP of Exchange 2010 is the 192.168.1.10 and the DNS is the ex2010.mydomain.com
The IP of Exchange 2013 is the 192.168.1.13 and the DNS is the ex2013.mydomain.com

For a mailbox that resides now on Exchange 2013:

On outlook I select the option "manually configure settings"
Under "Microsoft Exchange Server Field" if I enter the IP of Exch 2010 -> 192.168.1.10
The IP changes to the DNS of Exchange 2013, ex2013.mydomain.com
and the mailbox is connected.

Repeating the above steps using as the IP of Exch2013 192.168.13 and
I receive the message “The connection to Microsoft Exchange is unavailable......."

Is the common name and autodiscover responsible for the above mentioned error?

If yes, where should I navigate in order to change common name and pointer of autodiscover?
mamelasAuthor Commented:
In addition I have created on my DNS server the following:

1)An "Alias (CNAME)" with Alias name: Autodiscover and FQDN the FQDN of the Exchange 2013 Server
which is the ex2013.mydomain.com

2)A "Service Location (SRV)" with the name: _autodiscover , domain: mydomain.com , port number: 443 and host offering this service: autodiscover.mydomain.com.

Now, when I ping the "autodiscover.mydomain.com" from a client I receive a reply from the Exchange 2013.

But still I have the problem connecting to Outlook as per my previous post...Any Help Please?
mamelasAuthor Commented:
To sum up:

1) The CN of the Exchange's 2013 Self-signed certificate is now pointing to Exchange 2013 Server
2) The Autodiscover now resolves the IP of Exchange's 2013 Server

for a mailbox that is migrated/resides to Exchange 2013:
3) If I let Outlook 2007 to automatically configure settings, the mailbox is connected successfully
    (the only alert that I receive is that the security sertificate was issued by a not trusted company)

4) If I manually configure settings the Exchange 2013 server is not resolved neither by entering the
IP address nor by the DNS name.
(I have found that in case I enter the IP of Exchange 2010 and click "check name" button, the IP changes to the DNS of Exchange 2013 and the mailbox is connected.) But why??
MASEE Solution Guide - Technical Dept HeadCommented:
-->(the only alert that I receive is that the security sertificate was issued by a not trusted company)
This is because of the IIS not enabled on the 3rd party certificate. Instead it is enabled on self signed certificate
mamelasAuthor Commented:
That's true. I will buy a certificate the following days.

But what about 4) ???
mamelasAuthor Commented:
I have tried:
-      To shutdown the Exch 2010 in order to “push” outlook to connect and resolve the IP of Exch 2013, with no luck
-      I have pointed the CN of Exch 2013 to the IP of this Server
-      I have created an autodiscover entry and it is now resolves the IP of Exch 2013

The Exch 2010 Server was also a Primary DC/DNS server. I have transferred the DC and FSMO roles to a new DC.
The Exch 2010 Server has now only the Global Catalog.
Regarding Global Catalog & Exchange I have found the following resolution and I am wondering if this solves also my connection problems:

Cannot connect to or resolve Exchange Server name
mamelasAuthor Commented:
Dear Experts,

After a lot of search I have found the solution on my own.

First of all, you have to create some DNS entries:
1)      One “CNAME” entry autodiscover.mydomain.com that will point to the Exchange Server’s internal IP Address or DNS
2)      You should also create a “CNAME” entry for OWA for example, mail.mydomain.com.
Again it should point to the Exchange Server’s internal IP Address or DNS
3)      You should finally create an SRV Record with name _autodiscover pointing to autodiscover.mydomain.com

Second step is to decide if you will buy a Puclic Unified Certificate (UC) or use Exchange’s internal self-signed Certificate.
In case that you use the self-signed certificate and during configuration of outlook client you will receive a warning message and you should have to install manually this certificate.
Therefore on every outlook client you have to install manually the certificate.
In case that you will be using the Public certificate you will not have to take any action, regarding the certificate.

The last thing and the most important is that due to the new design of Exchange Server 2013, adding an outlook client manually requires different procedure compared to Exchange 2010 or earlier versions.

Before, in 2010, you should enter the FQDN of the Exchange Server or IP Address and the user’s mailbox was resolved after pressing the “check name” button.

Now on Exchange 2013 the outlook client is connected via RCP over HTTP.
Configure Outlook 2007 via RCP over HTTP

You will notice that after following the above procedure and press check name the Exchange Server FQDN ,you entered earlier, will change to a long number followed by @guid which is actually the unique ID number of the mailbox for the specific user (and this is a normal operation).

Please note that if you have configured the above DNS entries correctly you can let outlook to “autodiscover” settings and setup Outlook only by using user’s mailbox name and password
(provided also that you have installed a UC Certificate).

Hope it helps.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mamelasAuthor Commented:
-
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.