No task sequence found when deploying an SCCM build and capture task sequence

Hello

I created an SCCM 2012 task sequence to build and capture a server 2012 image.

Created a collection containing a computer with a mac address of a blank virtual machine, and then deployed that task sequence to the vm.

The vm boots into sccm but it then says that no task sequence can be found for the computer

Any ideas?

Thanks in advance
LVL 1
WolfAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CotillionCommented:
Try deploying the task sequence to the unknown computers group.

Are you trying to deploy or capture an OS to/from the VM?
0
WolfAuthor Commented:
I'm trying to deploy an OS to the VM, and then capture it, over PXE.

I tried deploying the task sequence to both the unknown computers group, and to the collection with the VM inside it.  It still says no task sequence available
0
deanomacCommented:
Has this Task Sequence been run on this device previously? Even if it didnt complete?

If so, clearing the required Task Sequences for that device record may solve it for you.

Though, my gut suggestion would be to leave the Task Sequence deployment to the All Unknown Computers collection active, then delete the VM record you have created.  Let the Unknown Computers collection pick it up and run the Task Sequence from there.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

CotillionCommented:
I agree, delete the computer record that is currently in the system and let the unknown computers collection do its thing.
0
WolfAuthor Commented:
Thanks, i left this overnight and tried again this morning.  It picked up all the tasks sequences that i tried to deploy yesterday, and i managed to capture the reference image.

Now, when i try to deploy that reference image, i deploy it to the unknown computers collection.  How long should it take for that task sequence to "hit" the unknown computers?

I have a new fresh blank Virtual Machine ready, but its saying the usual no task sequence found
0
CotillionCommented:
Do you have the same architecture on the VM as the image?

Also you need to make sure the the task sequence is deployed to the x64 or x86 boot image in order for it to pick up.
0
deanomacCommented:
The deployment should be virtually instant.  Have you added the VM to the SCCM Database?  If so, delete it.

Is it a completely new "just been created" vm with a completely new MAC address?? You can search SCCM database by a query for the MAC address to confirm it is not already in there:

select SMS_R_System.Name, SMS_R_System.MACAddresses, SMS_R_System.ResourceDomainORWorkgroup, SMS_R_System.Active from  SMS_R_System where SMS_R_System.MACAddresses = ##PRM:SMS_R_System.MACAddresses##

Open in new window


That is the query I use.  Just run the query and type in the MAC address of the device you are looking for.  Remember to insert a colon between each octet:  00:00:00:00:00:00

This query will show all entries in the database corresponding to that MAC address. You will then need to go to the Devices node and delete the relevant named device.  (Cant do it from inside the query unfortunately).
0
WolfAuthor Commented:
Yes, its a new VM with a new MAC address.

When i boot the VM i monitor the SMSPXE.log file and it sees that the device is not in the database, and then says "found optional advertisement EUR20043" which is the task sequence deployment.

However, once the VM has finished booting into SCCM, i get passed the pxe password screen, and it says no task sequence available.

If i then do a query for the MAC address or the GUID BIOS info it finds the device in the database, and SCCM has simply named it "unknown", but its not in the unknown computers collection.

I can then delete that from the database, run through the whole thing again, and the same thing happens where it sees its not in the database, but then adds it

See attached screenshots
ScreenHunter-208-Jul.-09-12.51.jpg
ScreenHunter-209-Jul.-09-12.55.jpg
ScreenHunter-210-Jul.-09-12.55.jpg
0
Nagendra Pratap SinghDesktop Applications SpecialistCommented:
Please upload smsts.log
0
deanomacCommented:
Just a quick thought, has your Task Sequence deployment been set to this for the unknown computers collection?

Deployment Settings
I cant easily check whether this would even give you the result you are getting, the environment I am working in at the moment has all standard Task Sequences available to all devices (PXE and Boot media only, and yes the risks have all but been mitigated! haha), but the above is the default setting when creating a Task Sequence deployment, so may have been overlooked.

Anyway, if it is set to the above, you will need to change it to be available to PXE and Boot media.
0
WolfAuthor Commented:
Thanks for the advice

It's very strange but i left the task sequence deployed for about 1 hour, and finally when i booted the vm into pxe it found the available task sequence and deployed the image.

However, I'm now trying to deploy the image to a live physical server:

1)  I configured the array directly on the HP server (is there a way to configure the array in sccm?)
2)  PXE boot and it loaded fine, but now comes up with the error message:  

An error occurred while retrieving the policy for this computer (0x80004005)

Any ideas?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
deanomacCommented:
1) Out of my comfort zone, one of the other helpful guys here may have more knowledge on that.
2) Error message translates to: Access Denied.  Which step did it die on? Do you have command support enabled on that task sequence?
0
WolfAuthor Commented:
Left the task sequence running overnight and it was picked up the next morning.  I wasn't being patient enough
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server Apps

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.