SBS 2011 WSUS Needs Help

Alright, so we have an SBS2011 server and it is sending out a health report with inaccurate WSUS information regarding failed updates. This prompted me to look into the database further and found that it seems to be a mess. I tried to run wsusutil reset from an admin command promp but this put out no message, text, or info of any kind to the screen and dropped me back into the command prompt. I then tried to run wsusutil listinactiveapprovals which sat blank for a long time and then pushed back an error that read "Unable to get a list of permanently inactive approvals from the WSUS server. Check that your WSUS server is running. Fatal Error: Timeout expired.  The timeout period elapsed prior to completion of  the operation or the server is not responding." I am not the best versed in WSUS and I have not been able to find anything online that addresses this as the hot topic of WSUS is apparently how to clean it out. Any thoughts?

Edit: The Microsoft##SSEE Database service is in a running state.
NMTSupportAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Larry Struckmeyer MVPCommented:
Hi:

First is to check Services and verify it is actually running.  Then  Start - Admin Tools - Windows Update Services - Tools - Clean Up.  Run each portion one at a time with the top one last.  If you have never done this, it will error out several/many times and have to be restarted but persevere.

Check the event viewer for related errors.  Let us know the Event ID and Source of those.
NMTSupportAuthor Commented:
Thanks for the post! I will schedule some time to remote in and give this a shot!
NMTSupportAuthor Commented:
I ran the steps per your instructions and it appeared to hang. Came back a day later and found a big red circle with a white 'X' that states: "Database Error" Double checked and all services are running. Thank you!
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Larry Struckmeyer MVPCommented:
In the error dialog box it should offer a chance to restart WSUS.  Once that is done, begin again.  It could take a long time and many resets.
NMTSupportAuthor Commented:
Just an update on the question: It is still failing and I keep restarting. I have noticed that the service keeps stopping every time the process starts. I have task manager running on the side and the wsusservice drops its PID and gets another about three times before it just ends in a stopped state. The current step is "Deleting unused Updates". Thank you again for your continued assistance!

Also, an event viewer warning pops up as follows (I have also verified that the specific SQL service remains running the entire time):

Event ID 7042

"The WSUS administration console was unable to connect to the WSUS Server Database.
   
Verify that SQL server is running on the WSUS Server. If the problem persists, try restarting SQL.
   

System.Data.SqlClient.SqlException -- Timeout expired.  The timeout period elapsed prior to completion of the operation or the server is not responding.
The statement has been terminated.

Source
.Net SqlClient Data Provider

Stack Trace:
   at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
   at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
   at Microsoft.UpdateServices.UI.SnapIn.Wizards.ServerCleanup.ServerCleanupWizard.OnCleanupComplete(Object sender, PerformCleanupCompletedEventArgs e)"
Larry Struckmeyer MVPCommented:
Normal.  The clean up wiz stops the service.  As I said, it will take a lot of re-starts to finish this.  Or you can use SQL Management to create a new database and not let it get so full.  If you need instructions on this post back.  But it is less complicated to just keep on resetting the data base and starting the clean up again.  And Again.  And Again....
NMTSupportAuthor Commented:
Update: still performing this.
NMTSupportAuthor Commented:
It still has not moved past the error. I think I would like to move forward with the creation of a new data base. Is there a process to this? Thank you!
Larry Struckmeyer MVPCommented:
Probably easier and cleaner on SBS to do a reinstall:

https://technet.microsoft.com/en-us/library/Gg680316.aspx

once done, get the WSUS cleanup wizard from codeplex and schedule it for whatever day your LAN is least used:

http://wsus.codeplex.com/releases/view/17612

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
NMTSupportAuthor Commented:
Update: Looking for SBS 2011 Media for this client's server. Will post again as soon as I am able. Thanks for your help and patience!
NMTSupportAuthor Commented:
Found the media for this server.

Cannot complete the steps to install based on the website. The steps are inconsistent and attempting to fill in the gaps does not work.

Continued on step 2 because WSUS was not listed

Step 3a - Created on D because C is a small partition. Also, this is where the WSUS currently resides.

Step 3c - The path to the exe is incorrect and using the correct path did nothing. Gave the system a few minutes and ran it again, nothing happened. Took the /q off and the extraction box came up and then said that it failed, see log. Opened the log and it just says "2015-08-04 16:43:48  Error     MWUSSetup          Product is already installed. Setup type specified is inconsistent with allowed action (Error 0x80041453)" along with a few other errors that state the same. I can't continue with the steps in the article. Is there a way to rebuild the DB without reinstalling? Thank you!
NMTSupportAuthor Commented:
Reinstalled WSUS  verbatim and everything seems happy now. Thank you for your help!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.