Linked Server Anonymous Login Error

I have a query that uses a linked server from a SQL Server 2012 instance to a SQL Server 2008 instance.  When I run the query directly on the SQL Server 2012 box using SMS, it works fine.  When I add the query to my BIDS 2008 client and try to use it within the Reporting Services report, I get this error.

"Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'."

What am I missing?  I've looked online, but have been unable to find a solution.
BMFCAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Deepak ChauhanSQL Server DBACommented:
Use the login in BIDS client which you have mapped in linked server security.
BMFCAuthor Commented:
In the Linked Server security, I have "Be made using the login's current security context"

My domain account has full access to all servers.
Deepak ChauhanSQL Server DBACommented:
Is your domain acocunt is using in the BIDs while connecting? If you are using sql authentication login then login should be with the same name should be existed in the remote sql server. If you are using windows authentication login, this should be permission on the remote server. Please check which login is using in BIDs.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BMFCAuthor Commented:
i ended up adding my domain account explicit rights in the linked server security and it worked.
BMFCAuthor Commented:
added domain account in linked server settings.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2008

From novice to tech pro — start learning today.