Plugging in USB flash drive doesn't work

I have several USB devices that work (KB, mouse, external HDD, BT adapter, etc.). But when I plug any USB 2 or 3 flash drive into any USB 2 or 3 socket, Windows 7 Pro says the driver could not be installed. The details are in the attached file. Thank you.
USB-Flash-problem.txt
E. Douglas (Doug) JensenConsultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ThomasMcA2Commented:
From microsoft.com:

Sometimes proper drivers do not get detected after the initial installation, so reinstallation of the drivers helps resolve the issues.

Disconnect all USB devices and then perform the following steps:

A.   Click Start, and then click Control Panel.

B.   Click System and Maintenance, click System, and then click Device Manager. Note If Control Panel is in Classic View, double-click System, and then click Device Manager. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.

C.   In Device Manager, double click to expand "Universal Serial Bus controllers", right click on the Host Controller, click "Uninstall" and click "OK".
Check if at all there is an exclamation mark along the driver, it suggests issues with the driver installed.

D.   Repeat Step C to uninstall all items under "Universal Serial Bus controllers".

E.   Then, restart your computer and Windows 7 will reinstall all USB controllers automatically.

If you still face the same issue then you may check for the updated USB device drivers using windows update. Refer to the below link for assistance–
http://windows.microsoft.com/en-us/windows7/Update-a-driver-for-hardware-that-isnt-working-properly
You can also try by going through Open the Hardware and Devices troubleshooter http://windows.microsoft.com/en-us/windows7/Open-the-Hardware-and-Devices-troubleshooter
Paul DawsCustomer Support Technical SpecialistCommented:
I'd try the boot menu options with a USB key inserted. (If you can get a bootable USB) that would be best.

This may then prove the hardware is working if you can at least see the USB key as an option in the BIOS boot menu.

Depends on the BIOS if it will see a none bootable USB in the menus.

Also are you admin on the machine as if not, it could be that a policy exists to stop USB drivers being installed.
nobusCommented:
i found SafelyRemove very handy for this kind of problems :  http://safelyremove.com/?pid=1
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

E. Douglas (Doug) JensenConsultantAuthor Commented:
I like safelyremove, but my problem is that USB flash drives are not recognized by the OS.
Paul DawsCustomer Support Technical SpecialistCommented:
I’d suggest you try to download and install the latest Windows 7 compatible chipset drivers from the machine manufacturer’s website to see if that will fix the issue.
nobusCommented:
if the problem is recent, asystem restore to a date when it was ok can help
E. Douglas (Doug) JensenConsultantAuthor Commented:
Thank you--I have been ill and not able to follow any of these suggestions until today. I'll get back to you with my results.
E. Douglas (Doug) JensenConsultantAuthor Commented:
First feedback:

* Paul, the manufacturer does not have the chipset drivers.

* Nobus, I may have to do that as a last resort, in that my latest system backup is very old (yes, I know...sigh).

* Thomas McA2, I was going to try this but I have seven USB host controllers, and 21 other devices under Universal Serial Bus Controllers (Hub, Root Hub, Composite USB Device, etc.). May I ask you if uninstalling everything is still the right thing to do? I hope Win7 has all the drivers needed to reinstall.
nobusCommented:
here some things to try :
Here a list of things to try :
-from Device manager scan for new hardware
-in device manager>view tab, click "show hidden devices" and delete all usb entries and hidden devices,  reboot and test
-then you can download the latest drivers for the chipset, and reinstall it to update the USB root hubs
-start>run>diskmgmt.msc      check if the usb devices show up in disk management, then run :   start>run>services.msc
In the listing look for removable storage service.
If it is set to Auto, and not started, then start it : click the Start link in the top left...
-In c:\windows\inf, look for usbstor.inf    -  If it is not there, you can copy it from another PC..When you find it, right click it and select Install

***instead of view hidden devices, try:
Right click Computer > Properties > Advanced System Settings at the left side > 
in the Advanced tab select Environment Variables >
 in System Variables click New and enter:  "devmgr_show_nonpresent_devices" without the parenthesis - enter 1 for the Value.
Click Ok and Exit.
Now delete all devices in device manager  that are not in solid black
Reboot and test
E. Douglas (Doug) JensenConsultantAuthor Commented:
New information: Looking at Device Driver (I was going to do the uninstall USB devices suggestion), I see that under Disk Drives, the hard drives and SSD look fine, but there are yellow ! in front of all four of these: Generic Compact Flash USB Device, Generic MS/MS-Pro USB Device, Generic SD/MMC Device, and SM/xD Picture USB device Device. These appear to be the front panel flash device sockets.
Paul DawsCustomer Support Technical SpecialistCommented:
This could also help if anything else suggested does not work...

Remove the INFCACHE.1 file

Perform the following steps to remove and rebuild the INFCACHE.1 file.

1. Disconnect all USB devices except the keyboard and mouse. (Desktop only) /
 (Laptop remove ALL usb devices)

2. Open Windows Explorer by right clicking on Start, and then clicking on Explore.

3. In the address bar, type

C:\Windows\System32\DriverStore

4. Locate the INFCACHE.1 file, right click on it, and then click Properties.

5. In the INFCACHE.1 Properties dialog box, click the Security tab, and then click Edit.

6. In the User Account Control dialog box, click Continue.

7. In the Permissions for INFCACHE.1 dialog box under the Group or user names section, click Add.

8. In the Select Users or Groups dialog box in the Enter the object names to select text box, type Administrators, postfixed with a 's', and not only Administrator.

If you only choose the Administrator account you will not be able to delete the file. After that, click OK.

9. In the Permissions for INFCACHE.1 dialog box in the Permissions for Administrators section, select to allow Full Control, and then click OK.

10. In the INFCACHE.1 Properties dialog box, click OK.

11. In the Windows Explorer window, delete INFCACHE.1, before deleting it, you can make a backup copy of this to another folder of you wish.

12. Connect a USB device other than the one that Windows had trouble detecting. This forces Windows to rebuild the INFCACHE.1 file.

Note: This detection issue can happen several times in a row. If so, repeat steps 1-12 until the device is detected.
E. Douglas (Doug) JensenConsultantAuthor Commented:
Thank you Nobus. I have to go to a doctor appointment now, so I will see if my previous comment affects anything you said, and otherwise I will embark on your latest suggestions. Thank you !!!!
E. Douglas (Doug) JensenConsultantAuthor Commented:
Thank you Paul--now I have a lot to try when I get back from the doctor.
nobusCommented:
>>   but there are yellow ! in front of all four of these: Generic Compact Flash USB Device  <<  this could maybe  point to a bad usb root controller
can you get it working with ANY usb device?
try updating the chipset driver also!
E. Douglas (Doug) JensenConsultantAuthor Commented:
I have not abandoned this topic, I am moving my residence and that has absorbed virtually all my time. But fixing this is #1 on my list, it is a big problem for me. Thank you all for your suggestions and patience.
nobusCommented:
no problem, i'll be around, so take your time
E. Douglas (Doug) JensenConsultantAuthor Commented:
OK today is "Fix the USB ports" day.

One suggestion included unplugging all the USB devices except the KB (and mouse?). I have never had anything except a KB and mouse in a USB port. Oops I also have a Bluetooth dongle--which works. The trouble began the first time I tried to add a USB HDD. Next ...
nobusCommented:
just try a ram stick - to be sure it works - and test if it works on other pc's
E. Douglas (Doug) JensenConsultantAuthor Commented:
Device manager shows the kb, mouse, and BT dongle as USB devices without problems (no yellow !). The list of HID devices is good. The Eltima USB stub (USB to network gate) is good--but I am not using it, so I think I will uninstall it. The Disk Drives -- four SCSI (eSata III) drives show good. Disk Drives Generic--the four interfaces for flash (SD, MMC, xD, CF) all have a yellow ! I think I will see if I can uninstall those Generic disk drives. Then reboot and return with the results.
E. Douglas (Doug) JensenConsultantAuthor Commented:
[EDIT 2] [EDIT] A RAM stick causes Windows to pop up a window with the correct brand name and "The device has been loaded" but it is not visible in the file browser but it is in the device manager with a yellow ! but not visible in the Disk Manager. The stick works on another PC.
E. Douglas (Doug) JensenConsultantAuthor Commented:
I will do nothing further until I hear back from you about that, THANK YOU!
nobusCommented:
>>  yellow ! in front of all four of these: Generic Compact Flash USB Device, Generic MS/MS-Pro USB Device, Generic SD/MMC Device, and SM/xD Picture USB device Device  <<  try updating the driver for it
what pcis this?  model or mobo plse ?
E. Douglas (Doug) JensenConsultantAuthor Commented:
I deleted those drivers, rebooted, and Windows reinstalled them with yellow ! The PC is a Origin and the mobo is a ASUS Z97 WS.

I am suspicious about that USB to serial program, I have never used it because it wasn't what I thought it was, so I think I'll uninstall it and reboot.
E. Douglas (Doug) JensenConsultantAuthor Commented:
That didn't make any difference to the USB drivers that still have yellow !
E. Douglas (Doug) JensenConsultantAuthor Commented:
[EDIT] This time I disabled the drivers and rebooted. They came back as disabled, but when I plugged in the USB flash drive Windows said it was installed but Device Manager put a yellow ! on it. Double clicking the flash drive in Device Manager gets the response "This device cannot start (code 10)" I sure hope that it helpful to you.
E. Douglas (Doug) JensenConsultantAuthor Commented:
The other four devices return code 22 when I double click them.
nobusCommented:
update your drivers  from here - for 64 bit Windows 7 :  https://www.asus.com/Motherboards/Z97WS/HelpDesk_Download/
start with chipset
E. Douglas (Doug) JensenConsultantAuthor Commented:
I decided to see if reinstalling just the USB drivers would work. I had previously uninstalled and let Windows reinstall the yellow banged drivers; rebooted and the reinstalled drivers were still yellow banged.

Next I went to the web site you linked and installed just the USB drivers, rebooted and they were still yellow banged.

It was suggested that I uninstall every USB driver and let Win7 reinstall them or reinstall them from the mobo driver site--but I am not certain that Win7 and the mobo site has all those drivers, the computer manufacturer might have installed some that come with USB devices and I don't see drivers available on the Origin site and wasn't provided with drivers for any added devices (maybe there aren't any added).

Attached is the Device Manager USB situation as it currently is.
usb1.jpg
usb2.jpg
E. Douglas (Doug) JensenConsultantAuthor Commented:
Those 4 yellow banged devices are the front panel flash card (SD, MMC, etc.) sockets--I wonder what would happen if I disconnected them from the mobo?
nobusCommented:
>>   front panel flash card   <<   did that come with the PC, or was it a separate one?
you have only to install the driver for it; but if you don't have these, it won't hurt the rest
you can disconnect it also, and see if it helps - but i doubt it
can you post  the model of the  front panel flash card ?
E. Douglas (Doug) JensenConsultantAuthor Commented:
The front panel flash card came with the PC. If no driver gets installed, I can live without flash cards, I need just USB. There is no manufacturer ID on it, so I have placed a service request to Origin.

Thus far, none of the above suggestions has solved the problem. Sigh.
nobusCommented:
may i ask to recapitulatewhat is ok now and what not -  the thread gets very long; so:
-do usb devices work now ?
-only the card reader is bad?

if you don't find any solution - try running from a free OS like ubuntu, or boot from a live cd like Knoppix, and test the devices

another solution is unmounting the device from the pc, and connect it to a working one for testing
E. Douglas (Doug) JensenConsultantAuthor Commented:
Paul, after infocache.1 was rebuilt, device manager still shows yellow bangs for the front panel flash card readers and no usb socket works. So Now I am going to open the PC and disconnect the front panel flash card device from the motherboard if I can.
E. Douglas (Doug) JensenConsultantAuthor Commented:
The front panel flash card unit is made by Rosewill.

I opened the PC and found the cable from the front panel flash card device terminated at a connector on a small board about 1"x3" that had been attached with double sided adhesive foam squares to a spot on the frame of the case. One end of the board had come loose and that end lifted into the air. I was skeptical but carefully reattached the board with its adhesive foam, taking care that nothing on the board shorted against the frame. That did not make the problem go away.

So I unplugged the front panel flash card cable and that made those four devices disappear from the Disk Drives list in Computer Management.

But the USB sockets still do not work except for the keyboard, mouse, and bluetooth radio. When I plug in a USB flash drive, it is correctly listed in Disk Drives but with a yellow bang like the front panel flash sockets had before I disconnected them.

FYI the small board is labeled USDB HUB and has 8 USB ports, two being type A and 6 being 10-pin headers. The front panel flash socket device had been plugged into one of the headers. There is only one spare header so I am going to plug the front panel flash card device into that instead of where it was and see if those sockets reappear.

When I plug a USB flash drive into either of the type A sockets on the card, the result is the same as plugging it into any type USB socket of the machine.

One more thing: Device Driver has a yellow bang for the AMDA00 interface in System Devices. I don't know if anything I did had changed that, I had not been looking down there until now. Google has many results for AMDA00 such as "I can confirm that the AMDA00 Interface driver by ASUS is in fact defective. Even in Windows 7, it does not work properly under some conditions." (I have an AMD mobo.) I don't want to delete that driver since I don't have a source for it, but I could rename it to see what happens. Others having trouble with that interface have a variety of problems I don't have, but I haven't searched for AMDA00 USB yet.
E. Douglas (Doug) JensenConsultantAuthor Commented:
I plugged the front panel flash card device back into the header where it had been but the device does  not appear as before under Disk Drives in Device Manager.
E. Douglas (Doug) JensenConsultantAuthor Commented:
P.S. In the comment about I accidentally said I have an AMD mobo when in fact it is an Asus. Sorry.
E. Douglas (Doug) JensenConsultantAuthor Commented:
There is no file on my system drive named amda00.
nobusCommented:
is it this one by chance?   http://www.newegg.com/Product/Product.aspx?Item=N82E16820223103

it uses generic drivers imo

>>  I plugged the front panel flash card device back into the header where it had been but the device does  not appear as before under Disk Drives in Device Manager <<  it should; so check if you plugged it in  correct - on some boards, you can dislocate it by 1 pin, or turn it around

**you can also connect it to another usb port for testing
E. Douglas (Doug) JensenConsultantAuthor Commented:
@Nobus: Here is the current status:

Out of the blue, plugging a USB HDD or flash drive into any USB socket, the device is recognized by Windows 7 (I can see in it Device Manager) but it is not assigned a drive letter and right (left? I can't remember) pops up a window that the device cannot be started. That sounds like a driver problem.
The keyboard, mouse, and bluetooth radio (ass USB devices) work correctly.

I deleted and reinstalled the USB drivers and that did not solve the problem. I tried all the suggestions people posted and none of them fixed the problem.

I also noticed that the front panel flash card devices listed under Disk Drives all had yellow bangs.

I unplugged the cable from the front panel flash card unit from a small USB hub card that had been added to the PC cabinet from with double sided adhesive tape. The hub card had come loose at one end and was hanging away from the frame. The front panel devices disappeared from Disk Drives in Device Manager where they had appeared. I plugged the front panel into the only spare USB header on that little card and the front panel was still not there. So I plugged the front panel back where it has been and still the front panel flash card sockets did not re-appear !

The little hub card has two type A sockets but USB devices to not get drive letters when plugged there either.

It does appear to be a driver problem but I can't fix it.
E. Douglas (Doug) JensenConsultantAuthor Commented:
*all (not ass) USB devices LOL
nobusCommented:
check in disk management if the usb drives are seen - and HAVE A DRIVE LETTER

i would install it correct; does the mobo not have a spare usb connector ?
what model motherboard is it?
E. Douglas (Doug) JensenConsultantAuthor Commented:
Thanks I'll respond to that in a moment.

But first: despite the USB sockets not working, the USB kB and mouse and Bluetooth radio--all USB--have continued to work. I assume that the KB and mouse have their own HID driver, a does the Bluetooth radio, so they wouldn't be affected by a USB driver problem. But just now I unplugged all three of those (the cables were too short for me to move the PC where I wanted to access the inside) and when I powered on, there is no KB or mouse (I didn't try the radio). I don't believe I did anything that I would expect to have affected their drivers.

(I am now using my laptop)

I have an Asus Z97WS motherboard. All of the mobo USB connectors are in use, plus there are four or five additional USB PCIe cards for additional USB 2 and USB 3 type A connectors. All those have been in use and working (external HDD's) until this disaster happened.

When I plug in a USB device (except the KB, mouse, radio), they show up in the Device  Manager disk drives with yellow bangs, and they do not show up in the Disk Manager.

Thank you for being so patient with me.
E. Douglas (Doug) JensenConsultantAuthor Commented:
I discovered that the KB and mouse work if plugged into a mobo USB ports, but not if plugged into PCIe USB port cards as they used to. I'll keep looking and reinstall drivers for PCIe USB cards.

But front panel flash card unit has yellow bangs for slots in Disk Management, and USB drives are identified but to not have drive letters and do have yellow bangs even when plugged into mobo USB sockets.
E. Douglas (Doug) JensenConsultantAuthor Commented:
OOps cable to PCIe USB came loose, mouse and KB work there now,
nobusCommented:
for drives not showing up after plugging, try the following :
Open up a command prompt, as admin
 Type the following:
 diskpart <enter>
 automount enable <enter>

it may be useful to list the pci usb cards, and the devices connected to it. then i can follow your explanations better
maybe one of them is malfunctioning, and causes problems for the others
maybe you can buy a new PCIe card (with at least 4 connectors) and test that out first - then use it to swap with others to test
or use a couple external, Powered usb hubs - 8 or even 16 port
E. Douglas (Doug) JensenConsultantAuthor Commented:
Thank you for that Nobus, I'll follow up.
I apologize for my tardiness--as I said before, I work full-time, and am doing all the stuff necessary to move my residence (and I have a handicap that slows me down). I appreciate everyone hanging in there while I work on this. Thank you.
nobusCommented:
no need for aplogy - i'll be 'round
i just wanted you to test each PCIe to usb card separately (one may influence the other), so have only 1 card instralled at the time for testing
when ALL test correct  -connect each time 1 more and test

also - it crossed my mind that your system seems to be loaded with a lot of hardware
maybe you better calculate if your power supply can handle the load :
http://extreme.outervision.com/psucalculatorlite.jsp
E. Douglas (Doug) JensenConsultantAuthor Commented:
Thank you. re power: I have a 750VA PSU, and the AC from my UPS goes to a digital power meter before it gets to the PC. As I type now, I am consuming about 180-225W/230-270VA. Of course it goes up when I transcode or something. Five 6TB HDDs (WD Reds) are currently powered, and 2 Blu-Ray drives.

I have other HDD's in external powered eSATA/USB 3 enclosures for data I need to move from one PC to another.

Thanks again.
nobusCommented:
ok -  that seems plenty of power
test the cards separately - to be sure which one is ok, or not
E. Douglas (Doug) JensenConsultantAuthor Commented:
@nobus: this afternoon I will remove PCIe to USB cards one at a time.
nobusCommented:
ok - take your time to sift the good from the troublemakers
E. Douglas (Doug) JensenConsultantAuthor Commented:
There are 3 PCIe to USB boards. I removed one at a time, but still no USB. There are USB headers on the mobo of course, I suppose I could unplug the sockets one at a time, taking care not to lose my kb and mouse.
E. Douglas (Doug) JensenConsultantAuthor Commented:
When I plugged the three boards back in, Windows installed driver(s) and listed a lot of USB hubs, controllers, etc., all with green checks. But none of the usb ports work except the kb and mouse.
usb1.png
usb2.png
nobusCommented:
>>  But none of the usb ports work   <<  are those all on the PCIe boards? or also on mobo ?
did you plug and test the boards one by one, as asked?
E. Douglas (Doug) JensenConsultantAuthor Commented:
Yes, I removed the pcie usb boards one by one, finally there was only the mobo usb.

The mobo ports don't work either except for kb and mouse--does that suggest there is still a driver problem despite win reinstalling the usb drivers since the kb and mouse use the HID drivers, right?

I am going to move the kb and mouse around to all the usb pcie and mobo usb ports to see if that tells me anything.
nobusCommented:
i start to think your mobo does not deliver 5V on the plug - can you measure that?
also post a device manager screenshot -  with usb device connected  -that does NOT work
E. Douglas (Doug) JensenConsultantAuthor Commented:
Yes I will do that. My BT radio is plugged into a pcie to usb card and it works. And the KB and mouse are plugged into a different pcie to usb card and they work. I will try to do as you ask when I finish work today. Thank you!
E. Douglas (Doug) JensenConsultantAuthor Commented:
I downloaded USBView from Microsoft. It lists all the USB controllers, hubs, ports--and says there is no device connected to any of the controllers.
nobusCommented:
and is that correct?
E. Douglas (Doug) JensenConsultantAuthor Commented:
Sorry, I should have noted that I plugged a USB 2 interface HDD or a USB flash drive into a socket on each of the three PCIe to USB cards, and into one of the MB USB sockets (it could be that the MB has more than one USB controller but I thought that having something plugged into any one of those would suffice). I used USB 2 to avoid any issue with a USB 3 driver which I recall Win7 didn't come with and I had to install separately. The MB does have USB 3. Thank you.
nobusCommented:
it' is becoming a long thread
may i ask you to re-start from beginning; i mean :
-only mobo  -no plug-in boards
test ALL usb outputs - with a ram stick and usb disk drive that has it's own power
all should be working

if one fails -  it's useless to proceed, so report back

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
E. Douglas (Doug) JensenConsultantAuthor Commented:
Will do.
E. Douglas (Doug) JensenConsultantAuthor Commented:
I will start over with a new thread, testing the pc as suggested.
nobusCommented:
ok
keep us posted !
E. Douglas (Doug) JensenConsultantAuthor Commented:
I have posted a do-over thread. Thank you.
nobusCommented:
can you post here the link to it?  then i won't miss it!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.