Avatar of GenieMaster
GenieMaster
 asked on

Hyper V Network Server

I have a server that has 4 Nics.  The operating system is Server 2008 R2.
This server is setup as a standalone Hyper V Server.
3 of the 4 Nics are associated to Virtual Networks, each Nic serving to a different network.

For example Nic 1 is not used by any virtual network and it is to this nic I am able to RDP into it and manage the server.
The ip address is 10.10.10.1 and it has a gateway that gives it internet access.

Nic 2 which is used by a virtual network has the ip 10.10.50.1
Nic 3 which is used by a virtual network has the ip 192.168.50.1
Nic 4 which is used by a virtual network has the ip 172.16.234.1

There are several virtuaul machines and workstations and they all respectively use Nic2, Nic 3 or Nic 4 depending upon the network they are connected to.

From the Server, Nic 2, 3 and 4 are all connected to switches that are part of that network.

The problem I am having is that if from the main server I am trying to access the internet but it says it cannot. On further investigation I note it is trying to go out via Nic 3 which has no internet access.

How can I get it so that the main hyper v server only uses Nic 1 ?
Microsoft Virtual ServerHyper-V

Avatar of undefined
Last Comment
GenieMaster

8/22/2022 - Mon
Peter Hutchison

You need to make sure that Nic 1 is the first card the server will use when trying to access the internet.

1. Open Control panle, Network and Sharing Center
2. Click on Change Adapter Settings on the left.
3. Press Alt+N to get the menu appear, in particular, the Advanced menu
4. Select Advanced Settings
5. Change the order of the network cards so Nic1 is at the top of the Connections list using the arrows.
Philip Elder

In Hyper-V Manager uncheck the "Share with management OS" option for the three virtual switches not being used to access the server.

That will remove the TCP/IP stack from the physical NIC for the host OS thus eliminating this conundrum.

I have an EE article Some Hyper-V Hardware and Software Best Practices that may be helpful.
GenieMaster

ASKER
Hi Peter, thanks for your suggestion.
I tried that out and moved the Physical Nic 1 to the very top above the Virtual and other Physical Nics but it still does not work.  I did an NSlookup and I could see it was using Physical Nic 1 based upon the DNS Server it was connected to.  I then did a test and disabled all of the other 3 virtual nics and I was able to access the internet from Physical Nic 1. I then tried to enable different virtual nics 1 at a time to see if it only happens on specific virtual nics but every time I enabled a virtual nic I was not able to access the internet via Phyiscal Nic 1. Any other ideas ?
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
GenieMaster

ASKER
Hi Philip,

If I uncheck the "Share with management OS" then the virtual Nics disappear from the network connections.  If I do this then how are you supposed to maintain the ip address settings for the 3 virtual networks I have ? Each virtual nic has its own specific IP Address which is part of that virtual network.
ASKER CERTIFIED SOLUTION
Philip Elder

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
GenieMaster

ASKER
Yes you are correct Phil, I always assumed that we needed to put a network address for the virtual network it belonged to but now realise that is only needed for when you are wanting to manage it via that nic. Thanks once again.