You do not have permission to run 'SP_TRACE_GENERATEEVENT'.

Hello,
I have set up sql replication on sql 2012 and when I run synchronization, I get the following message:

You do not have permission to run 'SP_TRACE_GENERATEEVENT'.

I am running the replication under user repl_merge as Microsoft recommends and have given alter_trace permissions to the user but I am still getting this message.

What other users do I need to grant alter_trace to for replication to work.

Also, I am aware this error is a known issue from Microsoft, but I need a work around.
LVL 1
H-SCAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vitor MontalvãoMSSQL Senior EngineerCommented:
Go to the replication jobs and check who is the user set in each of them.
Deepak ChauhanSQL Server DBACommented:
Try by granting sysadmin to repl_merge users.
Vitor MontalvãoMSSQL Senior EngineerCommented:
I was investigating the error and can be a bug. It's already reported here.
Looks like you'll need to give ALTER TRACE permission to the user.
EugeneZ ZhitomirskySQL SERVER EXPERTCommented:
also check this one "SQL Server 2012 Merge Replication - Delete operations on Merge Tables now require ALTER TRACE permission due to Extended Stored Proceedure call master..sp_repl_generateevent. Some Advise would be appreciated"

https://social.msdn.microsoft.com/Forums/sqlserver/en-US/2d62c253-cd39-42b6-941b-1c0c0ff9767e/sql-server-2012-merge-replication-delete-operations-on-merge-tables-now-require-alter-trace?forum=sqlreplication

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
H-SCAuthor Commented:
All,
Many thanks for the input.  I am aware that this is an open issue with Microsoft and hopefully it will get resolved.  I tried granting sysadmin to repl_merge user and even all of the users associated with the repl process.  I looked at the repl_user that is associated with the jobs that run and that user has alter_trace.  The only way I am able to work around this issue is to remove any article that has the needed alter_trace delete event and re add it when I make changes to the articles themselves, which is not much, just on occasion.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.