Help with networking lab. Connectivity to 2811 router.

I have a simple lab design so far.

2 x 2960 Switches successfully trunked. Port Fa0/1 is trunked to each other.

I introduced a 2811 router. I'm simply trying to ping interface fa0/0 and cannot do it from one of the switches. As this is a lab I'll provide the configs below in full.

Any help  is appreciated. I think I'm missing something very basic here. I haven't started the ROAS portion yet as I want to ensure I can ping the interface on the router first.


Switch:
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname hq-sw2
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 description **Link to hq-router1
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan5
 description **Mgmt
 ip address 10.1.10.12 255.255.255.0
!
ip default-gateway 10.1.10.1
!
!
!
!
line con 0
 password cisco
 logging synchronous
 login
 history size 100
 exec-timeout 0 0
!
line vty 0 4
 password cisco
 login
line vty 5 15
 password cisco
 login
!
!
end

Open in new window


Router config:

!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname hq-router1
!
!
!
enable secret 5 $1$mERr$hx5rVt7rPNoS4wqbXKX7m0
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
!
!
!
no ip domain-lookup
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface FastEthernet0/0
 description **Link to hq-sw2
 ip address 10.1.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description **Link to branch-sw2
 ip address 172.16.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
 history size 100
 exec-timeout 0 0
 password cisco
 login
!
line aux 0
 password cisco
 login
!
line vty 0 4
 password cisco
 login
!
!
!
end

Open in new window

mcananyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AkinsdNetwork AdministratorCommented:
We need to know how the devices are connected.
Please post a topology diagram or sketch.

- Is  fa0/1 on hq-sw2 the trunk link to sw1?
- which switch is the router connected to?
JustInCaseCommented:
interface FastEthernet0/24
 description **Link to hq-router1

interface FastEthernet0/0
 description **Link to hq-sw2
 ip address 10.1.10.1 255.255.255.0
 duplex auto
 speed auto

Router's fa0/0 interface sends untagged traffic, so that traffic belongs to VLAN 1 on switch since it is default VLAN on all switch ports, but router's interface Fa0/0 is in the same IP range as SVI for VLAN 5. So, you can resolve this (make switch and router ping each other) with add interface fa0/24 on switch to VLAN 5 as access port (and I guess that interface fa0/0 on router is not shut).
 :)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mcananyAuthor Commented:
There it is. Yes, fa0/1 is the trunk to the other switch. fa0/24 is the connection the router.

Capture.JPG
mcananyAuthor Commented:
Router's fa0/0 interface sends untagged traffic, so that traffic belongs to VLAN 1 on switch since it is default VLAN on all switch ports, but router's interface Fa0/0 is in the same IP range as SVI for VLAN 5. So, you can resolve this (make switch and router ping each other) with add interface fa0/24 on switch to VLAN 5 as access port (and I guess that interface fa0/0 on router is not shut).
 :)

Predrag,
That worked. It makes sense. The interface IP address is an IP on that VLAN 5 network. So in order to ping that interface I needed to setup that port as an access port on VLAN 5. I have a quick question though.

Lets assume at some point that I will have multiple VLANS on that side of the router. Will I want to make that a trunk instead? Is this where Router on a Stick comes into play?

Lastly, if I introduce OSPF, would I still set them up as trunks?

Sorry, I'm obviously a beginner.

Thank you!
JustInCaseCommented:
If you setup multiple VLANs  on switch you need to setup trunk just as you expect, that is router on a stick.
Simplified - if you want to introduce OSPF - you can't setup OSPF  with 2960 switch (OSPF is not supported on 2960). :)
With L3 switch (OSPF is usually supported on those) you would setup it differently. You would set port as L3 port with
# no switchport
command, and then you would assign IP address to port, and then configure routing protocol.

And don't worry about being beginner, we were all beginners at some point, no need to apologize.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.