Cannot print from IE 11

I've got a Dell laptop, running 64 bit Win 7 Pro, that I cannot print from Internet Explorer 11 or 10. Computer was recently wiped out & re-installed, but not sure what version of IE was being used before, but there was no problem printing. I can print from Chrome or Firefox with no problem. I have tried running as administrator, tried disabling protected mode & have tried running it with no add-ons. After that, I rolled it back to IE 10, tried all the same 'fixes' & got exactly the same result, a box popping up saying 'There was an internal error, and Internet Explorer is unable to print this document'. I the page setup, I have also tried removing header & footer. Printer is a SAvin MPC3502, with the PCL6 driver. Other than just switching to another browser, any suggestions?
LVL 1
gromackAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bigeven2002Commented:
Hello,
Since other browsers print fine, this likely points to the IE browser.  Are you able to print to the XPS driver?  That should be one of the default printers on a fresh install of Windows 7.

I am referencing KB973479 from Microsoft below.

Try updating the video driver.  IE 10 and 11 use hardware acceleration by default.  You can also try turning the acceleration off under Internet Options > Advanced.

Second, see if the Low folder exists inside the default temp folder.  Open the Run menu (Win+R) and type %temp% and press enter.  Is the Low folder present?  If not, create it.  Then close the Temp folder and restart IE.  Then retry printing.

If the Low folder already exists, then the integrity may need to be restored.  Open and administrative command prompt and type:
ICACLS "%userprofile%\AppData\Local\Temp\Low" /setintegritylevel (OI)(CI)low

Open in new window

Then reboot the machine and retry printing.
0
arnoldCommented:
Agree with bigeven, if this is an AD environment. Setup a user GPO that creates the directory, and sets the permissions.
0
gromackAuthor Commented:
I have tried all of the solutions offered there & still NOTHING!

Jeeeee-zus, I hate Internet Explorer...
0
Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

arnoldCommented:
Can you output into an XPS printer? Does print preview display any info or is it showing a blank page?
Try compatibility mode depending on what it is you are trying to print.
0
gromackAuthor Commented:
Actually, if I just hit print, I get nothing. No error message, nothing shows up in printer. The only way I'm able to find out that it doesn't work is to hit print preview & from there tell it to print. I'm so irritated at the moment, I left before I broke something, haha! I'll try the XPS option & any other suggestions sometime tomorrow.
0
arnoldCommented:
Usually, the print resulting in empty pages deals with a missing %temp%\low missing which is used by IE to store data there temporarily. Using the icacls to set a lower setting on the low  directory.
The combination should fix the issue.
If you see data in the preview display, the issue might be with the printer driver.

Presumably, you can trigger the printing of a test page.
0
gromackAuthor Commented:
The same pages will print fine out of Chrome or Firefox.
I wasn't getting an empty page, if I just went to File>Print, I wouldn't get anything, no error message, nada, zip, zilch.
0
arnoldCommented:
If preview displays information, double check printer properties when printing dealing with quality.
Any chance to see logs in the printer I.e. Somehow your print tries to go color, while printer denies color prints from you.

Try setting quality to black and white ..........

The issues with IE11 and the referenced low is that IE would print blank pages, but pages will come out.
0
gromackAuthor Commented:
I got this resolved by changing to the PCL 5c driver.
FYI, I could print to XPS & everything on the page would display, but then trying to print that gave me the error message 'The XPS Viewer cannot print all of the pages of this documant'.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bigeven2002Commented:
Interesting.  Ok thanks for the update and glad you got it working.
0
gromackAuthor Commented:
What do I do about awarding of points for this?
0
bigeven2002Commented:
If any other responses helped then choose accept multiple solutions and then choose your reply on Pcl 5c as the main solution and then others as assisted solutions accordingly and then determine how many points those assists were worth.

  If none of the other responses helped then just select your reply as the only solution.  No points will be given but it will close the question properly.
0
gromackAuthor Commented:
It was the one that worked...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.