Reinstall of Microsoft CRM 4.0

I am trying to move our CRM installation to a new server on another domain. Through searching I found that I need to create a new organization and then import the original org. I find that a bothersome error has gone and another has replaced it. I am getting a timeout expired msg (see attachment). I am not sure if the issue has to do with a busy SQL server or??? I intend to wait until tomorrow morning to attempt again in case it is a matter of system being busy, but wanted to ask if someone has seen this before.


http://www.experts-exchange.com/Software/Microsoft_Applications/Microsoft_Dynamics/Q_24616701.html
timeout.PNG
MPMITAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Feridun KadirPrincipal ConsultantCommented:
The error message certainly suggests that the SQL Server might be busy and slow in responding or it could be that it is not responding at all. This could be a firewall issue (is SQL on a different server?) or you specified the SQL server incorrectly.

There is also an issue with Reporting Services validation which could be due to the same issues as for SQL Server.
0
MPMITAuthor Commented:
Hei, SQL is on a different server, but within the same domain. I can remote to so know that it is up and running. Is there something that can be done to test the cause of the error?
0
MPMITAuthor Commented:
There is connection between the systems I have a remote screen open from the SQL server, I can see the MSCRM_CONFIG is created, also the new DB I created appears briefly until the error message appears and then it all dissappears.
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

Feridun KadirPrincipal ConsultantCommented:
Hmm, that suggests that a firewall is not an issue. What version of SQL Server are you using? I don't think CRM 4.0 is supported on anything after SQL Server 2008 and what version of Windows are you using for CRM?

Also, check the log files on the CRM server, these are in the user profile of the installer under Appdata\Roaming\Microsoft\MSCRM.
0
MPMITAuthor Commented:
We have SQL server 2008 R2, attempting to install CRM on Server 2008 R2 system as well as just 2008. Both give the same messages.

If it is a matter of 4.0 not being able to install on R2, what version would you suggest and would be be able to import and use our current db into the newer version.  Also, I presume that we would have to purchase a new license, does that sound correct?
0
MPMITAuthor Commented:
Meant to attach the log file if you have time to take a look at it, I removed some names but should not have any bearing on the issue at hand.
crm40svrsetup.log
0
Feridun KadirPrincipal ConsultantCommented:
According to the Microsoft compatibility matrix at https://support.microsoft.com/en-gb/kb/3005186 SQL Server 2008 R2 and Windows Server 2008 R2 are supported. However, you should select update installation files during the install. If you are already doing this I suspect your problem will require someone to connect to your servers to diagnose the problem.

There have been several versions since 4.0, these are 2011, 2013 and 2015. You will have to buy a new license unless you bought software assurance (SA). If you did then you are entitled to the version that was available when you software assurance ended.

You can upgrade use your existing database in later versions, but you have to upgrade a version at a time. So, if you decide to go for CRM 2015, then you will need to first install CRM 2011, import the database and then upgrade to CRM 2013 and then upgrade to CRM 2015. There are various ways to approach the upgrade.
0
Feridun KadirPrincipal ConsultantCommented:
Unfortunately the log file doesn't give anything extra. It does show that setup waited around 35 seconds before timing out.

This article https://support.microsoft.com/en-gb/kb/957053 also suggests that you must update the installation files.
0
MPMITAuthor Commented:
Question, the reportingGroup and PrivReportingGroup and the like are they not created when CRM installs? I am looking at the SQL SMS console and see Domain\SQLAccessGroup {0d147...........} and others under Security -> logins.
These do not exist under the new SQL server, but the groups exists in the new Domain, but I get an error when I try to add them, msg is that group does not exist, but I can see them in AD.
0
Feridun KadirPrincipal ConsultantCommented:
Each time CRM is installed a new set of groups are created in AD. If you do not have any CRM deployments on your domain you can delete all the CRM related groups in AD and SQL.

You do not need to/should not create the groups/logins in SQL. The CRM install does that. Is your installing account an administrator on the SQL Server? Being Domain Admin does not guarantee that you are an administrator.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MPMITAuthor Commented:
My user is sysadmin, thought that should be sufficient.
0
MPMITAuthor Commented:
Using a Network service Account, should I be using Domain user acct?
0
Feridun KadirPrincipal ConsultantCommented:
You do not have to use a domain user account though it is recommended. The CRM 4 implementation guide has lots of information on installing CRM 4.0.
0
MPMITAuthor Commented:
Feridun, first thank you for your time.
I have been going around and around with this, if I had any hair I would have pulled it out.
I am trying again having gone through the implementation guide. I am at the stage to specify reporting services server. Install guides states "To verify taht you are using the correct URL, in a browser, type the Report Server URL as the address". Of course I get the error 404 page does not exist. Am I to create this on the CRM server? What comes up by default is http://<servername>/ReportServer, I have been going with this and of course get the same message each time 404. Is not the ReportServer on the system with SQL? If not how to set up ReportServer, IIS is installed on this system.
0
Feridun KadirPrincipal ConsultantCommented:
Reporting Services is a feature of SQL Server however I don't think it is automatically installed when SQL Server is installed - it depends on the options selected when SQL Server is installed.

On the SQL Server, run the SQL Server Installation Center and select Tools, Installed SQL Server features discovery report. This will show whether SSRS (reporting services is installed). If it isn't then in the Installation tool, select Installation, New SQL Server ..... or add features to an existing installation; follow the instructions to add SSRS to the existing instance of SQL. Make sure you select Native for SSRS and not SharePoint. After the install, you will need to run Reporting Services configuration manager. Then the URL that you tested should work.

Don't go looking for Reporting Services in IIS, it doesn't add a website to IIS; it runs its own web server.

Good luck!
0
MPMITAuthor Commented:
Again can not express how much I appreciate you timely responses.
I see that we have reporting services on the SQL server, but when I attempt to test using http://servername/ReportServer I get the msg "The permissions granted to user `\smithja are insufficient for performing this operation. (rsAccessDenied).
I am confused because if I go into server management studion under security ->logins my user is listed as sysadmin. Where else do I need to go to add permissions for the report server?
0
Feridun KadirPrincipal ConsultantCommented:
Try reviewing this link https://msdn.microsoft.com/en-us/library/bb630430(v=sql.110).aspx

I think it might be relevant and I recall having this problem before.
0
MPMITAuthor Commented:
A step closer. I am able to access reports and reportserver from the SQL server, but still not for CRM. Have been attempting to troubleshoot the connection issue over the weekend, but to no avail. Not sure if this was part of the problem you may have experienced feridun, any suggestions or other links?
Thank you
0
Feridun KadirPrincipal ConsultantCommented:
Do I have this right?  You can browse to the reports and reportserver URLS on the SQL server but not from a browser on the CRM server.

If so, what message do you see in the browser on the CRM server?  Is it page cannot be displayed (which suggests a name resolution or firewall issue) or something else?
0
MPMITAuthor Commented:
Sorry for the delay in responding. Had to take a day from headpounding.
Yes, if I am on the SQL server I can connect, however I have to open IE as administrator and still have to put in username password. I followed the link you provided and was able to add myself as administrator but still have to input username and PW, not sure if this is part of the issue. From CRM message is IE cannot display the webpage.
0
Feridun KadirPrincipal ConsultantCommented:
Hmm. I think this is going to be difficult to diagnose without hands-on, have you considered engaging someone?

Until you can browse to the reporting services server in the browser on CRM, there is no point trying to complete the CRM install.
0
MPMITAuthor Commented:
Not sure if this is proper, but do you have a phone maybe I can engage you?
0
MPMITAuthor Commented:
Some success, I was reading back through our transcript and saw (again for the 100th time) firewall.
It did dawn on me regarding the server built in FW, I was thinking network FW. Can I spell Idiot, would be my name.
Port 80 was not enabled, now that it is I am able to connect, so attempting to install now.
0
MPMITAuthor Commented:
Back to original issue, "timeout" on Microsoft SQL Server, Reporting services completes fine.
0
Feridun KadirPrincipal ConsultantCommented:
Great that there is some progress. Try also opening port 1433 which is what SQL needs. Another test is to temporarily turn off the firewall (if you are permitted to do so) to see if that helps.
0
MPMITAuthor Commented:
Good news is that I got the process to complete on my test environment. Using the same CRM server against a test SQL server all went well. However, against my production SQL still get the timeout error, report manager is okay. This is totally confusing. Will take the time to review both setups. Did briefly turn off FW on production, no change. Any ideas?
0
Feridun KadirPrincipal ConsultantCommented:
I've run out of ideas . I think you need some hands-on troubleshooting now,
0
MPMITAuthor Commented:
Thank you so very much for your time and effort
0
MPMITAuthor Commented:
Would like to thank feridun for all his time and efforts. Though have not gotten situation completely resolved, have gotten very close.
0
Feridun KadirPrincipal ConsultantCommented:
Thank you for the points and I'm sorry we didn't get to resolve this completely.

One thing did occur to me to ask you to check is when you specify the SQL Server name in the CRM 4.0 setup, are you including the SQL instance name (you only need to do this if it isn't the default instance), e.g. SQL1\production ?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Enterprise Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.