Windows 7 Mapped Drives

Our Windows 7 clients continually show mapped drives as unavailable until you click on them.  Then they work once you click on the mapped drives but any applications requiring mapped drives to be functional fail until connection in restored by clicking on the mapped drive in explore.  Is there a patch to fix this or registry setting to fix this from happening?

We even have one machine where the drive show disabled 100% of the time but still work when you click on them and don't refresh explore to show available.
Matthew FlemingAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NVITCommented:
Possibly UAC? https://support.microsoft.com/en-us/kb/937624/en-us?p=1

How are you mapping the network drive letters?

Have you tried NET USE Z: \\sharename /persistent:y

Change Z: to your needs.
1
Matthew FlemingAuthor Commented:
No I haven't tried persistent.  I'll give it a try.

Thx
0
akbCommented:
I have had similar problems on slow machines.
To fix it I used a login script with a delay to give the PC time to finish starting properly before mapping the drives.
1
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

nobusCommented:
this may help also :  from : http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/mapped-network-drive-is-connected-but-shows-as-not/4ac5ff92-863c-4921-8632-e38cbd136fb4?auth=1

http://support.microsoft.com/default.aspx/kb/937624?p=1

To configure the EnableLinkedConnections registry value, follow these steps:
1.Click  Start , type   regedit   in the  Start Search    box, and then press ENTER.
2.Locate and then right-click the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

3.Point to  New , and then click   DWORD Value .
4.Type  EnableLinkedConnections , and then press ENTER.
5.Right-click  EnableLinkedConnections , and then click  Modify .
6.In the  Value data   box, type  1 , and then click  OK .
7.Exit Registry Editor, and then restart the computer.
1
Matthew FlemingAuthor Commented:
All suggestions will be used going forward.  What ended up fixing it was disabling the IPv6 on all connections.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
akbCommented:
matfle, did you disable IPv6 to resolve the problem?
0
Matthew FlemingAuthor Commented:
Although the others may help the root of the issue was IPv6
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.