Remote Desktop Not Working Windows 7

Hi there

I have got 2 Windows 7 Computers one is desktop and the other one is a laptop both running Windows 7 Ultimate. Both of them got AVG Internet Security installed with firewall disabled on both of the machines. What I am trying to do is to establish a connection from my laptop to the desktop with no luck.

What I have done so far
1)Apply the remote assistance settings on the desktop in System-> Remote-> Remote Assistance-> Allow remote assistance to this computer. The funny thing in these settings is I do not have the remote desktop portion in the advanced system settings of remote i.e when I click advanced there is no Remote Desktop options for the desktop computerLaptop.pngDesktop.png. Please refer to the pictures.

I have read at some tech forum that I need to install update KB2574819; which I did and also I need to install Windows6.1-KB2592687-x64  to get the remote desktop working but the I wan unable to install the 2nd update as the Desktop System says "The update has already been installed"

I re-iterate myself I want to establish a remote desktop connection from my laptop to my desktop, both locally and over the internet. I want to do it locally first. Both are on the same network connected via the router and they can browse the internet and I can even control both of them via teamviewer from each other.
In the 2nd step I would like to establish a Remote Desktop Connection to the desktop computer via the internet. And for that What I have done so far I have forwarded the required port 3389 in my router along with the corresponding IP of my desktop computer. I have also disabled the AVG Internet Security Firewall to have any success but there was no luck. Ideally your answer would also include the solution to get the Remote Desktop connection going without disabling the AVG Internet Security Firewall.


Any help would be great. I have checked the previous answers regarding the same issue but was not of much help. Thx
SmukhtarAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Robin CMSenior Security and Infrastructure EngineerCommented:
Seems this was a bug/problem with Windows 7 SP1.
Did you see this possible fix?
From an Administrator command prompt type: regsvr32 %systemroot%\system32\remotepg.dll
Otherwise can you uninstall and re-install the KB2592687 update?
0
Seth AllenSenior ConsultantCommented:
Since you're using this in a home environment, why not just use TeamViewer?  It's free for non-commercial use and should give you exactly what you're looking for.  If it won't let me know what you're trying to do and we can find a solution.

https://www.teamviewer.com/en/index.aspx
0
SmukhtarAuthor Commented:
@robincm
Executing regsvr32 "%systemroot%\system32\remotepg.dll"
and
uninstalling update KB2592687 did not make any difference.
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

SmukhtarAuthor Commented:
@ Seth Allen

I am currently using teamviewer and I find it easier to read the text via Remote Desktop connection. I have installed an application which is actually an exam that require a lot of reading. It is not as good to look at the screen via teamviewer as Remote desktop.
0
SmukhtarAuthor Commented:
Awaiting any solution experts
0
Robin CMSenior Security and Infrastructure EngineerCommented:
How about:
slmgr.vbs -ipk <your windows license key>
You need to reboot afterwards (same as when trying the regsvr32 command above)
0
rindiCommented:
Are you sure both systems are Windows 7 ultimate? To me it looks more like one of them is a home version of Windows 7 which would be the reason you don't have the Remote Desktop Option in your view. The home versions can't be RDP'd into, they can only connect to other Remote Desktop PC's.
0
SmukhtarAuthor Commented:
@robincm

Executed slmgr.vbs -ipk <your windows license key> and restarted without any luck
0
SmukhtarAuthor Commented:
@rindi

I confirm both machines in question are running windows 7 Ultimate
Untitled.png
0
Robin CMSenior Security and Infrastructure EngineerCommented:
You can turn on Remote Desktop access via the registry:
HKLM\System\CurrentControlSet\Control\TerminalServer
Set the value fDenyTSConnections to 0

Also then check if the three Remote Desktop services are started: Remote Desktop Configuration, Remote Desktop Services, and Remote Desktop Services UserMode Port Redirector.

Check if RDS is listening by running:
netstat -aon | find "3389"
You should get a response similar to this if it is working:
  TCP    0.0.0.0:3389           0.0.0.0:0              LISTENING       1344
  TCP    [::]:3389              [::]:0                 LISTENING       1344
0
SmukhtarAuthor Commented:
@ robincm

Changed HKLM\System\CurrentControlSet\Control\TerminalServer
the value fDenyTSConnections to 0

Still no luck

and also copied the text

netstat -aon | find "3389"

and pasted as it is on the command prompt. Nothing happens
0
Robin CMSenior Security and Infrastructure EngineerCommented:
OK, I give up. Reinstall the OS or log a call with Microsoft. Sorry!
0
SmukhtarAuthor Commented:
Dear Experts

I should re-phrase my question. If you guys could look at the pictures in the question picture 1(Laptop running Windows 7 Ultimate) shows there is some extra options available but those options are missing in the 2nd picture (Desktop running Windows 7 Ultimate). why is that. I believe the answer lies in that question. As my laptop has got these options I am able to establish a Remote Desktop Connection to my Laptop and as it is missing in my Desktop Computer I am unable to establish a Remote Desktop Connection to my desktop.

By the way I forgot to mention both machines are running a non-genuine copy of Windows 7 Ultimate.
0
rindiCommented:
If they are non genuine, that could be the reason. Maybe the one that doesn't have the remote options, even if it says that it is the ultimate version, actually is a home version that gives out the wrong value for the version.

Get Genuine versions of Windows 7 and use those.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Robin CMSenior Security and Infrastructure EngineerCommented:
OK, so non-genuine software gets no support, so you're stuck. You get what you pay for! (or not)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 7

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.