Configure nested ESXi host virtual machines DHCP configuration.

I have a nested ESXi environment which can be illustrated (very roughly) as:

[Server 1 - Remote Workstation]
Physical ESXi Host Server
    Nested ESXi Host Server
         Virtual Machine

Alongside this I have another virtual machine running a domain controller in VMWare Workstation where I have configured a DHCP server. The virtual Domain Controller can ping all of the addresses of the components listed above as can the development machine itself.

[Server 2 - Development Machine]
Virtual Domain Controller

I have assigned the virtual machine a E1000 network adapter type and configured a fixed MAC address for it. Currently when I start the virtual machine I get the error message 'PXE-E51: No DHCP or proxyDHCP offers were received'. I believe this is because the virtual machine cannot find the domain controllers DHCP server across the network (guess).

Within VMWare Virtual Network editor I have bridged the NICs between the development and remote workstations to enable the required connectivity between the components - but as a result of doing this configuring DHCP becomes disabled so I cannot configure this to use the DHCP server on my virtual domain controller. So what I am wondering is how I can force the virtual machine/esxi host/... to use the DHCP server running on my development machine. Assuming this is the problem...

Has anyone out there done something similar in the past? Any help appreciated as I am out of ideas!
Blowfelt82Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NinjaStyle82Systems AdministratorCommented:
you get the 'PXE-E51: No DHCP or proxyDHCP offers were received' error when you turn on the Workstation VM? Does it boot to Windows after this error?

Is Server 2 on the same network subnet as Server 1?

Also, why the nested set up?
Blowfelt82Author Commented:
Yes the error occurs on startup, I have only only configured one vNIC (E1000) so after that I get an 'operating system not found'. I am trying to install ESXi via a PXEBoot so this wouldnt end up booting Windows but doesnt get this far anyway. As far as initial testing I will be happy if starting the VM takes out a DHCP lease on the domain controller...

The nested setup is a result of not enough physical kit to test on, I am working on the install, configuration and import of multiple ESXi servers into a vCenter inventory. Nested ESXi servers allow me to run multiple servers for initial testing without all the extra kit. This is a design decision above my head though and I am sure there are other reasons.

Is the subnet mask on the NICs what you need to know? They are different: 255.255.255.0/255.255.252.0 could this be the problem?
NinjaStyle82Systems AdministratorCommented:
If they are on seperate subnets the DHCP packets will need to be relayed. if your physical switch supports ip-helper that is an option, otherwise i would put a dhcp server nic and the client on the same network subnet.
SolarWinds® VoIP and Network Quality Manager(VNQM)

WAN and VoIP monitoring tools that can help with troubleshooting via an intuitive web interface. Review quality of service data, including jitter, latency, packet loss, and MOS. Troubleshoot call performance and correlate call issues with WAN performance for Cisco and Avaya calls

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
When nesting ESXi in ESXi, did you make sure that you used

on the HOST networking for the VMs.

1. E1000 interface.
2. also used the VLAN 4095 (ALL)

You may also want to refer to my EE Article and AutoLab.

HOW TO: Set up a lab environment for vSAN using VMware Workstation

(I know it states Workstation, the article contains links to AutoLab for ESXI!)
Blowfelt82Author Commented:
I have configured the VM with one vNIC which uses the E1000 adapter type, when I start up the VM it does attempt to obtain a DHCP address but fails so I assume the VM is configured as it should be and the problem lies elsewhere - is this what you mean or should something be configured on the physical/nested ESXi servers? AutoLab looks interesting I will have a look tomorrow...
NinjaStyle82Systems AdministratorCommented:
Blowfelt82, are they on the same network?

Like, are they both connected to the same switch, with the server bridged and the workstation bridged to that switch? or are they on the same vswitch?
Blowfelt82Author Commented:
The server and workstation are on a bridged network...
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
did you check VLAN 4095 (ALL)
Blowfelt82Author Commented:
I have assigned a network connection TEST-LAN to my VM with an adapter type on E1000, then on the host network properties I have edited the TEST-LAN properties to use VLAN ID 4095. I have also enabled promiscuous mode, mac address changes and forged transmits... Unfortunately still no luck...

Sorry for the late reply, my development environment got messed up last night! Any other ideas?
Blowfelt82Author Commented:
The error has progressed to 'PXE-E53: No boot filename received'. I have configured a boot filename using the correct MAC address format in the WDS boot images repository - however even though the error message does not refer to DHCP I am not seeing a DHCP lease being made in the DHCP console.
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
are DHCP params, set correctly.
Blowfelt82Author Commented:
Very new to DHCP but I think so...

I have setup a DHCP scope with a range of addresses on the same subnet as the ESXi host and given the DHCP scope the 060 PXEClient option... is that what you had in mind?
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
what are you deploying?

we use 66 and 67.
NinjaStyle82Systems AdministratorCommented:
Yeah you need option 67 set to a filename.

Are you using wds?http://m.windowsitpro.com/networking/configuring-dhcp-and-wds
Blowfelt82Author Commented:
Voila, I am getting somewhere a DHCP lease has been registered but now I get the error:

PXE-T04: Illegal operation error
PXE-E36: Error received from TFTP server
PXE-M0F: Exiting Intel PXE ROM

Andrew the points are yours, but if you care to shed any light on this feel free! I seem to be hitting every error possible along the way...
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
what are you 66 and 67 settings ?

it's now communicating via TFTP..... so is the filename path correct, does file exist....

there are no firewall blocks for TFTP on server or network ?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Blowfelt82Author Commented:
Problem solved, values in the scope options were wrong. Thanks for all your time on this you have been a lifesaver - really appreciate it.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DHCP

From novice to tech pro — start learning today.