SQL Server Management Studio - Unable to attach to an MDF file in my user profile.

I downloaded an MVC template onto my development machine a dropped it into the projects folder in my user profile (C:\Users\jdana\projects\gld_ember_mvcspa). An MDF and LDF file came along for the ride with the template. They're located here: C:\Users\jdana\projects\gld_ember_mvcspa\App_Data. For the life of me, I can't get SQL Server Management Studio to read from or attach to any MDF file in my user profile. (I'm running MSSQL 2014 Standard on a Windows 7 box.) Here's what I've tried thus far.

The following http://stackoverflow.com/questions/2330439/access-is-denied-when-attaching-a-database looked like a dead-match to my issue. I've given my local login account explicit full permissions to the projects folder and all child folders (making sure to logout/login afterwards).
I gave my local login account ownership of the projects folder and all child folders (making sure to logout/login afterwards).  
I checked login associated with the MSSSQLSERVER Windows Service, it's NT Service\MSSQLSERVER. I gave this login full permissions to the project folder (making sure to logout/login afterwards).

Finally, I launched SQL Server Management Studio with a right-click Run As Administrator.

None of this worked. My user profile folder remains inaccessible to SQL Server Management Studio.
jdanaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kyle AbrahamsSenior .Net DeveloperCommented:
Best to move the MDF files outside of your user profile.  

Windows can be a big pain when trying to grant access to the "users" folder (and below).

Create a new folder directly on C:  call it databases
Move the MDF / LDF folder in there
Grant full control to MSSQLServer
Then try attaching the databases.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Vitor MontalvãoMSSQL Senior EngineerCommented:
What's the error message?
0
jdanaAuthor Commented:
I'm perplexed. I now have access to my user profile in MSSQL Management Studio. One of the above-mentioned tasks got the job done. While I had logged out/in multiple times, I hadn't rebooted. That makes me think it was the permissions associated with NT Service\MSSQLSERVER that made the difference.

Kyle - I'm inclined to take your advice anyway. Given the fact that MSSQL doesn't "like" data living in user profile directories.

Thanks!

J
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.