can not connect to ANY network "network timeout" CAN connect to my iPhone via hotspot

I've followed all the advice I can find online
including changing location, reinstalling OS, starting in safe mode, deleting network adapter settings from system preferences
was working fine then wasn't
no change of any kind (that I'm aware of) prior to failure
Console-LogonAttempt.rtf
radb0yAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
What model Mac? Exactly what OS version?
radb0yAuthor Commented:
MacBook Pro (13-inch, Late 2011) OSX 10.10.4
strungCommented:
So it will connect by Wifi to your iPhone, but not to any other wifi network?
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

strungCommented:
Have you run wifi diagnostics:  https://support.apple.com/en-ca/HT202663  ?
radb0yAuthor Commented:
strungCommented:
This line:

07/14/15 12:24:59.0980 Wi-Fi interface is off, will not run configuration tests

seems to suggest your wifi is turned off.
radb0yAuthor Commented:
radb0yAuthor Commented:
here are more results from wifi diagnostics
AppS-2015-07-14-063708-Roberts-MacBook-P
radb0yAuthor Commented:
I assure you my wifi is on
strungCommented:
Have you tried deleting all your preferred networks?
strungCommented:
The last log you posted suggests that you have nariabox installed. You might try removing it.

Also try creating a new admin user, log in as the new user and see if your wifi works.
strungCommented:
Looks like you also have another trojan call Inkeeper. To get rid of it:

Go to applications/utilities and open activity monitor. Within 30 seconds under the tab "cpu" you should see innkeepr pop up in the queue. Click on it then select quit. Once done open applications in finder and choose move to trash for the innkeeper application. Empty trash.

You should probably also download and run an anti-virus scan like the free Avast:

https://www.avast.com/free-mac-security
radb0yAuthor Commented:
ran AdawareMedic got rid of nariabox
tried logging in as different loser, same results
radb0yAuthor Commented:
got rid of innkeeper(and a few others like it) as well
radb0yAuthor Commented:
deleted entire wifi connection and created a new one
radb0yAuthor Commented:
with network open in system preferences, when I try to connect, wifi shows connected (green light), then "no ip address" then simply "on" (yellow light)
strungCommented:
Do you have it set to DHCP?
radb0yAuthor Commented:
and yes I'm online right now via hotspot on my phone
radb0yAuthor Commented:
DHCP yes
I also tried copied TCP/IP settings from my phones network connection and entered them in manually
did not work
strungCommented:
Can you connect anywhere else, say at a Starbucks?
strungCommented:
Have you tried rebooting your router?
radb0yAuthor Commented:
not trying to connect to my router
have tried several networks, 2 public and one private
also with network open in system preferences, when I try to connect to public wifi, wifi shows "self assigned IP" (yellow light)
serialbandCommented:
Open terminal.app and ping the Google DNS to see if you can reach outside?

ping 8.8.8.8

If you can ping that, then you are connected.  This also suggests that your DNS is broken.  You have have accidentally added a DNS IP and prevented DHCP from assigning you one.

Also:
What IP address did you get?  Hold down the alt key when you click on your Wifi Status to see your IP and router info.   Ping your Gateway or Router.  If you can't ping that, then you have no connection.  If your IP starts with 169.229.x x then you actually aren't connected.  It should be one of the local LAN ips that start with 10. or 192.168.1.
radb0yAuthor Commented:
good morning
I appreciate your feedback
can not ping, not connected
"self assigned" IP I mentioned was 169.229.x.x

next?
strungCommented:
Try running the Apple Hardware Test:  https://support.apple.com/en-ca/HT201257

Have you ever had the computer apart, say to replace RAM or the hard drive? Is it possible the wifi antenna wire has come loose?
radb0yAuthor Commented:
will try but I found a suggestion on OS X daily
"Unload & Reload discoveryd to Fix DNS & Wi-Fi Failures in OS X Yosemite"
but when i tried, i got a response "no such file or directory"
it appears that /System/Library/LaunchDaemons/com.apple.discoveryd.plist
is missing
strungCommented:
Discoveryd only exists in OS 10.10.0 to 10.10.3. It was removed in 10.10.4.
radb0yAuthor Commented:
can't get AHT to launch I've shut down and started my laptop 4 times now
but with a loose wifi cable I wouldn't be able to see available networks or connect to my phone wirelessly
David AndersTechnician Commented:
You have removed and reinstated Wi-Fi in Network Preferences.
You have started in Safe Mode and tested.
You have been infected with multiple adware apps
You have logged in as a new admin test user.
You can not connect to multiple test Wi-Fi networks, but can connect to iPhone hotspot.
You can not run Apple Hardware Test.

Running iStumbler or the inbuilt Mac WiFi Diagnostic may be useful
http://download.cnet.com/iStumbler/3000-18508_4-10221917.html
http://osxdaily.com/2012/07/31/wi-fi-scanner-mac-os-x-mountain-lion/
In modern versions of Mac OS X like OS X Yosemite, OS X Mavericks, you can get to Wireless Diagnostics from the Wi-Fi menubar item:
    Option+Click on the Wi-Fi menu item in OS X
    Choose “Open Wireless Diagnostics”
How to Open the Wireless Diagnostics app in OS X
This is somewhat hidden, but still much easier than accessing it in prior releases of OS X where the app was basically hidden.

Booting with another version of OSX - Mavericks, MLion if your model supports them may point in a direction.
If you have access to another Mac, booting in Target mode with that Mac would allow you to boot into that working OSX

A trip to a Genius Bar may be in order.  https://www.apple.com/retail/geniusbar/
serialbandCommented:
Discovery was determined to be problematic so they went back to mDNSResponder.  Here's what you should use to reset the DNS:
sudo killall -HUP mDNSResponder

I don't think that's your problem.  You don't have a valid IP address.  This tells me that you aren't getting DHCP.  You can post pictures of you WiFi settings so that we can better help you.

What DNS servers are you getting?  What is the router IP that shows up?  What are you normally supposed to get?  Is it the 10.0.0.x or 192.168.1.x?


I would just recover the OS.  It's probably quicker that way.  It won't wipe your data, but it's always best to back up your data before doing any sort of recovery.  Since you don't have WiFi, you may want to download a copy of Yosemite from another system and put it on a USB.  If you have a wired ethernet port, then you can connect that way.
David AndersTechnician Commented:
The Google for "yosemite wifi issues" brought up this
http://furbo.org/2015/05/05/discoveryd-clusterfuck/
Indicating that Apple devices on your network can poison local access.
http://blog.chron.com/techblog/2015/06/fix-for-os-x-yosemite-wi-fi-problems-is-finally-on-the-way/

When you go to the Library, delete and reinstate WiFi in Network Preferences, start in Safe Mode, and login in new test admin account.....
Do you see the same problem.
radb0yAuthor Commented:
davidanders
thanks for your input
      When you go to the Library, delete and reinstate WiFi in Network Preferences, start in Safe Mode, and login in new test admin
      account.....
      Do you see the same problem.
yes
wifi diagnostic summary was no help but the diagnostic file generated must have some clue
problem is I don't know which log or crash file to look in or even what I should be looking for

i'd love to attach the file but mostly contains extensions that are not accepted for upload
maybe someone more knowledgable than myself could tell me which file would be most useful and i can generate a txt
radb0yAuthor Commented:
serialband
also thanks
tried the sudo command no change
i agree concerning valid IP adress
with network open in system preferences, when I try to connect, wifi shows connected (green light), then "no ip address" then simply "on" (yellow light)
i don't get ANY DNS servers although my iPhone tells me its the 10.0.0.x
i CAN connect wirelessly to my iPhone hotspot(and have internet access)
i've attached pics
first thing i did was reinstall OS
TCP-IP.tiff
radb0yAuthor Commented:
other pic
DNS.tiff
David AndersTechnician Commented:
Library same symptom, Huh.
In Network Preferences, Wi-Fi, DNS tab, click + button and add 8.8.8.8, click again add 8.8.4.4    (these are Google DNS)
open browser and test.
Exact Error Message in browser?

Apparently iPhone uses  172.20.10.1 as it's local IP address and is likely giving your mac 172.20.10.2
It seems to use 172.16.206.215 as it's DNS Server
Description . . . . . . . . . . . : Apple Mobile Device Ethernet #3
        Physical Address. . . . . . . . . : 42-A6-D9-94-82-9D
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 172.20.10.2
        Subnet Mask . . . . . . . . . . . : 255.255.255.240
        Default Gateway . . . . . . . . . : 172.20.10.1
        DHCP Server . . . . . . . . . . . : 172.20.10.1
        DNS Servers . . . . . . . . . . . : 172.16.206.215
                                            172.16.206.215
radb0yAuthor Commented:
com.apple.network.identification.plist
doesn’t exist in /Library/Preferences/SystemConfiguration/
i may have removed it inadvertently when refreshing the network configuration and preferences files
could this be a problem?
radb0yAuthor Commented:
i don't get an error message
David AndersTechnician Commented:
Using one browser? Safari? Or three, for testing?
radb0yAuthor Commented:
i'm not following
i'm currently connected via hotspot
can browse no problem
can't connect  to other networks
opening browser (safari) returns "failed to open page" "you are not connected to the internet"
serialbandCommented:
Get a screenshot of your settings when you can't connect.  What do they show when you can't connect?
radb0yAuthor Commented:
not sure what has changed
at one point in troubleshooting the WiFi momentarily displayed green connected
Screen-Shot-2015-07-15-at-2.17.52-PM.png
Screen-Shot-2015-07-15-at-2.18.12-PM.png
Screen-Shot-2015-07-15-at-2.26.16-PM.png
radb0yAuthor Commented:
here's what console reports while trying to connect
7/15/15 5:40:33.657 PM mDNSResponder[98]: mDNS_RegisterInterface: Frequent transitions for interface en1 (FE80:0000:0000:0000:6AA8:6DFF:FE2B:300C)
7/15/15 5:40:36.983 PM mDNSResponder[98]: DeregisterInterface: Frequent transitions for interface en1 (FE80:0000:0000:0000:6AA8:6DFF:FE2B:300C)
David AndersTechnician Commented:
Testing with Firefox and or Chrome is unlikely to be useful.
You have deleted wi-fi connection with the minus tab at the bottom of list of connections.
Restarted.   Created a new Wi-Fi connection the plus tab at the bottom.
And you have no problem with ethernet connections.
EtreCheck is unlikely to point to the solution, but have you run it?
Have you restarted your wireless router? Are other devices (iPhone) using the Wi-Fi connection successfully?
radb0yAuthor Commented:
OMG
just set up my personal router and connected
NO PROBLEM
so 2 of the 3 networks I was trying to connect to are complementary hotel networks
the third is a private network setup by the hotel
i hooked y router to a hardline also provided by the hotel
its seems my mac address is being blocked

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
radb0yAuthor Commented:
no to EtreCheck
yes to other devices
i don't have access to the routers i was trying to connect to
strungCommented:
Do you have to log into the hotel networks with a browser? Maybe a pop up blocker is blocking the log in page.
radb0yAuthor Commented:
yes
but that doesn't explain why i can't connect to the private network
strungCommented:
The problem may be that the hotel wifi signals are too weak for you to connect. You can connect to the iPhone because it is right beside the computer.

This could also be an indication of a problem with your antenna for the same reason.

Can you connect to your home wifi or any other wifi if you are right beside the router?
radb0yAuthor Commented:
duh
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Mac OS X

From novice to tech pro — start learning today.