2012 RDS Group Policy - Adobe Reader and Acrobat to Co-exist

I have a 2012 RDS session host that 20 users terminal in to.
We have always had Adobe Reader installed for users to open PDF files.
10 of the users required Adobe Acrobat Pro, so we obtained a license for 10 users to access Acrobat Pro.
We installed Acrobat Pro on the RDS session host, which also has Reader installed.
The problem is, when a user opens a PDF file, it is opening with Acrobat Pro.
I need to set the the default PDF program to Adobe Reader. I tried configuring a GPO per the article below:
http://www.grouppolicy.biz/2011/09/how-to-use-group-policy-to-change-open-with-file-associations/
However, the default is still Acrobat Pro.
What is the best way to accomplish this task at hand?
LVL 1
CCtechAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Robin CMSenior Security and Infrastructure EngineerCommented:
Are you running a full desktop session into the RDS host?
For one of the users where the new group policy preference isn't taking effect run:
gpresult /h %userprofile%\gpr.html /f
and then look in the gpr.html file to see if the GPPref setting has been found, and/or if the GPO has been applied to that user.

It might be that the installer for Acrobat Pro is doing some clever stuff at each logon and re-claiming its file extensions. So you might have to try and run any "fix" after this happens, which could be later in the session initialisation than GPPrefs. Maybe a .cmd file in the Startup folder in the Start Menu of the non-Acrobat Pro users that runs some oldskool ftype and assoc commands:
ftype AcroExch.Document.DC="C:\Program Files (x86)\Adobe\Acrobat Reader DC\Reader\AcroRd32.exe" "%1"
assoc .pdf=AcroExch.Document.DC
CCtechAuthor Commented:
Thank Robin, this ended up not being a fault with group policy applying. After research I found in 2012 R2 and Windows 8.1 are set per user with a unique hash in the registry. Therfor applying gp preferences will never work. I followed this guide to finally get this working:

http://blogs.technet.com/b/mrmlcgn/archive/2013/02/26/windows-8-associate-a-file-type-or-protocol-with-a-specific-app-using-a-gpo-e-g-default-mail-client-for-mailto-protocol.aspx

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CCtechAuthor Commented:
link to guide to solve
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Adobe Acrobat

From novice to tech pro — start learning today.