Antimalware programs won't run

This is a Windows XP Home system on an AMD 32-bit computer running Panda 2013.
I have read (without confirmation) that Malwarebytes' latest release won't run on these.
And it doesn't.  But I wonder:

If I run Malwarebytes OR RogueKiller, the programs stop immediately with an error that includes words like:
""Anti~mal~ware Tool" won't run....."

When I look in the registry, the same words show up in some of the keys that are associated with these programs:
""Anti~mal~ware Tool"   .... yes, with the tildes in there just as shown.

I've run just about all the scans I can think of including Kaspersky Rescue Disk 10 from CD and ESET online scanner.
But nothing seems to fix this problem.

I wonder if anyone has seen ""Anti~mal~ware Tool" ???  I don't find it in web searches at all.
LVL 27
Fred MarshallPrincipalAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David AtkinTechnical DirectorCommented:
It sounds like a virus infection could be stopping the program from running.

Download and install SuperAntiSpyware.  The scanner has an option for 'Alternative start' which will start the program under a different name (i.e. sadsad.exe) instead of its actual name.

See if the scan runs.  If it doesn't, start the machine in safe mode and try again.
0
Thomas Zucker-ScharffSolution GuideCommented:
Try chameleon from malwarebytes.org.  run the svchosts file from the chameleon directory. This will kill known rogue processes. it will update MBAM. Then run an mbam scan.


Https://www.malwarebytes.org/chameleon
0
Fred MarshallPrincipalAuthor Commented:
Chameleon: svchost.exe failed to load the master.conf file this time....
Generated the exact same error as described above the first time I ran it.

SAS hasn't found anything (yet).  Ran quicker scans first.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Thomas Zucker-ScharffSolution GuideCommented:
I have never seen chameleon not run. Have you run any rootkit tools?

Check out this article  on free antirootkit tools.  Run at least three.  What are the results?
0
Fred MarshallPrincipalAuthor Commented:
I ran about 3 of them as well as Combofix.  
Nothing seems to catch anything that helps.

I started a case with Malwarebytes with a set of logs they ask for.  
I'll post back what I learn.
0
Thomas Zucker-ScharffSolution GuideCommented:
Keep us apprised.
0
Fred MarshallPrincipalAuthor Commented:
It appears that this issue is related to old hardware and new software incompatibility.
Malwarebytes has published a workaround (which I've not tried).
It's at the end of this thread:
https://forums.malwarebytes.org/index.php?/topic/170525-malwarebytes-anti-malware-version-2181057-is-not-working/

Presently, the machine appears to be squeaky clean and still won't run RogueKiller's latest release.
Probably another incompatibility issue but they've not addressed it yet.

I was mistaken about "Anti~mal~ware Tool"   This appears to be a label used inside RogueKiller.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Fred MarshallPrincipalAuthor Commented:
Thanks to everyone who tackled this one for parasites (as did I).  
It's appreciated!!
0
David AtkinTechnical DirectorCommented:
Thanks for posting the malwarebytes link. Hopefully it will help someone else as well.
0
Fred MarshallPrincipalAuthor Commented:
Thanks again.
I tried the workaround and it worked.  Looks like a couple of .dll replacements.
It didn't fix RogueKiller though .. no surprise but hope springs eternal.
1
Fred MarshallPrincipalAuthor Commented:
RogueKiller in an older version worked as well.
1
Fred MarshallPrincipalAuthor Commented:
This is a very strange problem that likely won't get much attention because the hardware at the center of it is quite old.
Yet, if one is trying to keep an XP system running, they could run into it.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Anti-Virus Apps

From novice to tech pro — start learning today.