HP ML310e Gen8 / Server 2012 R2 - USB Drives wont appear

As per subject, having an issue with 2 servers which have usb3 drives attached and windows won't recognize them at all.

In device manager, looking at hidden devices, the 2 usb drives seem to be listed as Generic Volumes under Storage Volumes section.

I have tried to get KB2822241 installed but it says it is not applicable no matter what I do. Windows Updates shows there are no updates pending, and the event viewer doesn't log any errors.

The CBS Logs don't give away much either other than hundreds of 'no parent found, go absent' messages when trying to install the aforementioned patch. Seems like a prereq is missing but I can't find anything online for this patch having any prerequisites. All I can think of is that KB2822241 seems to be for many other fixes and I don't have those roles or features installed, and therefore can't get the problem fixed until I can identify what this is and install it first, then run the patch.

Has anybody had this problem before or know what KB2822241 requires, and if so, help!

Thanks.
LVL 3
sparky2156Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David Johnson, CD, MVPOwnerCommented:
it is an update rollup so you probably already have all of the individual components

what the probable cause is that the drives are 'offline'
going old school you can start diskmgmt.msc and then put them online and assign a drive letter
Rob WilliamsCommented:
Have you checked if there is a USB3 driver available from the HP site for your server.  Last months Proliant e-mail alerts had a link to an advisory that a driver was required to address your problem if running 2008 R2.  I didn't see mention of 2012 R2, but worth checking.
http://h20565.www2.hp.com/hpsc/doc/public/display?sp4ts.oid=7500985&docId=emr_na-c03835163&docLocale=en_US
Scott KunauSr. Consultant/Managing PartnerCommented:
I agree with Rob.  Recently tried to build a VMware vSphere 6.0 on a ML 350 G9 and it kept failing until we found a specific HP modified version of the VMware .iso file then it worked perfectly.  

I'd bet there is a specific third-party (HP) driver that you need for server 2012 that will only be found on the HP website.

Scott

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gheistCommented:
ML310e G8 has USB 2.0 ONLY
ML310 G8 v2 has 2 USB 3.0 connectors in back of server. You can use all other USB ports without any drivers.
Davis McCarnOwnerCommented:
I don't think KB2822241 has anything to do with your problem.  If a device only appears when you show hidden devices, it is because the PC doesn't think it is there now and it should also appear under disk drives.
Are you logged in locally and as the domain admin?
Has anyone applied GPO's to prevent enumeration of disk drives?
Do the drives work on another PC?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.