USB device not recognized - mouse, Windows 7

I was temporarily without my normal mouse for my laptop so I tried using a Microsoft bluetooth mouse. I plugged the little bluetooth plug into my USB port and watched as Windows automatically installed about five different drivers. The mouse didn't work so I took it out and reverted to using my touchpad.

Now I have my original (corded) mouse back and I plug it into the USB port and get a "USB Device Not Recognized" message. The mouse works fine in a different USB port but not the one that it was originally plugged into. I'd like to get the original port (that was working fine yesterday) working again because it's on the proper side of my laptop for how my mouse is positioned.

I've tried a variety of things to fix this problem:

1. Powering off the laptop, unplugging it, removing the battery, pressing power, waiting 10 minutes, putting the battery back in, plugging it in again, restarting.

2. Deleting unused USB, mouse, and human interface drivers.

3. Deleting my valid USB, mouse, and human interfaced drivers and letting Windows refind and reinstall them.

4. System Restore.

5. Checking the upper and lower filter values in the registry (there were none).

One more detail: the problematic port works fine for other USB devices - an external hard drive or even another bluetooth mouse dongle I put in. It just doesn't work for corded mice.

Any other suggestions? This is very frustrating.

Thanks in advance!
jrmcanada2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sarabandeCommented:
you may look at this article: http://www.faqforge.com/windows/uninstall-usb-drivers-on-windows-7/

the point is that you have to uninstall the wrong device what should solve the issue that the usb port no longer is accepting the (normal) corded mouse.

Sara
0
jrmcanada2Author Commented:
Thanks for the suggestion, but I had already tried that.
0
☠ MASQ ☠Commented:
Do you just see an "Error 10" in Device Manager (DM) when the corded mouse is plugged?

Is there anything showing in DM under Human Interface Devices if you switch to View > Show hidden devices?
(With both types of mouse)
0
Cloud Class® Course: C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

rindiCommented:
Boot the system to a Live OS and see if the mouse works there. If it doesn't, you have probably physically damaged the plug on the PC.

A good Live DVD, which you can also use on a USB stick, is PCRepix:

http://pcrepix.sourceforge.net

Also check the plug with your eyes for traces of damage. If the plug is damaged there wouldn't be too much you could, short of opening up the laptop and unsoldering the current plug, then replacing it with a new one that fits.
0
jrmcanada2Author Commented:
When I plug the mouse in, I get an "Unknown device" entry that appears in Universal Serial Bus controllers.

The whole Device Manager list keeps refreshing every second or two so it's hard to get any kind of reading on what the settings are on that. When I do manage to right-click and select properties, I get an error 45 saying that the device is not connected.

Nothing new seems to show up under Human Interface Devices or Mice.
0
jrmcanada2Author Commented:
The mouse works in that port when I boot from a Live OS
0
☠ MASQ ☠Commented:
OK the Live OS means it's a Windows issue not a hardware one

Given the story so far I'm guessing that the Bluetooth stack installation has corrupted the driver cache and the association with that port.

To fix that go to C:\Windows\System32\DriverStore,  

You need to remove INFCACHE.1 and copy safely as a backup to another location.

Copying and pasting to a safe location is simple but because INFCACHE.1 is a system file owned by SYSTEM and marked by Windows as in use you won't be able to easily delete it

So we need to use a utility to get that bit done (or if you know your way 'round Windows you can simply take ownership of the file)


Download Unlocker
http://www.emptyloop.com/unlocker/


From this link
http://www.emptyloop.com/unlocker/download.php


Run the installer - but beware that the really useful Unlocker program is bundled with a whole lot of rubbish that you definately DON'T want to install. So read each page of the installer carefully

I've put a guide together here if you're not sure which options to choose
http://www.experts-exchange.com/articles/12939/Downloading-Safely-or-How-Not-to-Get-More-Than-You-Bargained-For.html

When Unlocker is installed it adds a right-click context menu option

Use this to delete the file to INFCACHE.BAK

Unlocker may determine that the file cannot be deleted while in use and will offer to remove it at reboot.  OK this.

Remove any connected USB devices and restart the computer.

To get INFCACHE to rebuild you now need to insert a USB device that requires Windows to install a driver from its existing store.  Plug the USB mouse into the port you want to use.

You should see the familiar USB Installing Software icon on the taskbar.
0
jrmcanada2Author Commented:
Hi again,

Thanks for the help. I already have Unlocker on my system, so I appreciate your warnings about the garbage it's bundled with.

I moved INFCACHE.1 to a backup folder (leaving no copy of it in \windows\system32\driverstore), unplugged my USB devices, and restarted. Regrettably, it hasn't changed the problem.

I'm not sure if this will help or not, but I noticed three things in this process:

1. Even when I plugged other USB devices in afterwards, I didn't get the USB Installing icon ... the devices just worked.

2. I checked and INFCACHE.1 has been recreated.

3. INFCACHE.1 was approximately 2 MB before and after the process (it's slightly smaller now than before).

James
0
jrmcanada2Author Commented:
In case it matters, whenever I plug the mouse into the affected USB port, the "USB Device Not Recognized" balloon message pops up. It shows for a couple seconds, disappears for a second, and then pops up again. This will repeat for as long as I leave the mouse plugged in.

If I click on the message, I get the attached message window.

Error message
0
☠ MASQ ☠Commented:
Have you tried deleting the hub from DM yet?

Strange you didn't get an installing drivers message - INFCACHE usually needs an unrecognised device to kick in the rebuild it shouldn't be there just on restart.

What's the multifunction device showing on the other port?
0
nobusCommented:
there are a lot of possible causes and fixes, so you can try these :
------------------
Here a list of things to try :
-from Device manager scan for new hardware
-in device manager>view tab, click "show hidden devices" and delete all usb entries and hidden devices,  reboot and test
-then you can download the latest drivers for the chipset, and reinstall it to update the USB root hubs
-start>run>diskmgmt.msc      check if the usb devices show up in disk management, then run :   start>run>services.msc
In the listing look for removable storage service.
If it is set to Auto, and not started, then start it : click the Start link in the top left...
-In c:\windows\inf, look for usbstor.inf    -  If it is not there, you can copy it from another PC..When you find it, right click it and select Install

***instead of view hidden devices, try:
Right click Computer > Properties > Advanced System Settings at the left side > 
in the Advanced tab select Environment Variables >
 in System Variables click New and enter:  "devmgr_show_nonpresent_devices" without the parenthesis - enter 1 for the Value.
Click Ok and Exit.
Now delete all devices in device manager  that are not in solid black
Reboot and test
i also found Safely Remove very handy  :  http://safelyremove.com/?pid=1
-------*******
-Change start type in registry
The idea is that the registry value for START has been changed to either 3 or 4 instead of 0, 1, or 2; 3 is Manual and 4 is disabled, 0 is SYSTEM (at kernel boot), 1 is SYSTEM (at login), 2 is AUTOMATIC
Default is 2 for this type of device
path:   HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Services/USBSTOR
Click on "Start" then modify binary data --> change to 02 instead 03 or 04

----------------------------------------------------------------------------------------------------
Remove old hardware devices :
go to Start>right click My computer>properties>device manager
in the view tab - click : "show hidden devices"
inspect  device manager for all hidden devices, and remove them

http://support.microsoft.com/kb/925196

OR :
Remove all USB drivers with:     https://filedb.experts-exchange.com/incoming/ee-stuff/6853-RENEWUSB.zip      ---> Now reboot and test.
Delete the "UpperFilters" and "LowerFilters" registry values from:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000}

you can also reset the usb :
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbstor.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usb.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbport.inf
rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 C:\WINDOWS\inf\usbprint.inf

OR :
Download devcon :  http://support.microsoft.com/kb/311272
then run :   devcon enable @usb\*
0
jrmcanada2Author Commented:
Hi Masq,

I tried the INFCACHE procedure again and this time I did see it rebuild when I plugged a USB device in. Regrettably, that hasn't changed the situation.

I'm not sure what the multifunction device is - how do I find out? I do have a Bluetooth mouse dongle plugged into another USB port. (This is my normal setup - I have the Bluetooth mouse dongle plugged permanently into one USB port and I use that Bluetooth mouse at home. I have a corded mouse that I use at my office, plugged into another USB port. That's the one I'm having all the trouble with now.)
0
jrmcanada2Author Commented:
Nobus,

Thanks for the list of suggestions. I've tried most of them. I'm having a couple issues:

When I right-click and select Install for usbstor.inf, I get an error message: The INF file you selected does not support this method of installation.

The link to https://filedb.experts-exchange.com/incoming/ee-stuff/6853-RENEWUSB.zip seems to be invalid.

Thanks again!
0
nobusCommented:
the EE link works fine for me...
0
jrmcanada2Author Commented:
I tried the the EE link again and was able to download the file. But when I run RENEWUSB, it seems to fail on every line. Is it compatible with Windows 7? Does it need to be in a specific folder?
0
nobusCommented:
it's been a while i used it, so i'm not sure
you can try the other suggestions also

you can make a bat file from the source code here  also :  http://www.robvanderwoude.com/files/renewusb_2k.txt
0
☠ MASQ ☠Commented:
"I do have a Bluetooth mouse dongle plugged into another USB port"

Ahh! this isn't going to be helping - the original problem happened as a result of the BT Stack and drivers getting installed.  Wiping out the cache isn't going to fix this while there's still a BT device being detected during the cache rebuild.

When I described how to reset INFCACHE one of the lines says: "Remove any connected USB devices and restart the computer." that's important!

This might not fix it yet but while there's still a USB device in the picture during the reset it's just confusing things.
0
sarabandeCommented:
to add to above:

you also may switch off bluetooth at your smart phone or other devices while installing/uninstalling.

Sara
0
jrmcanada2Author Commented:
Hi

Just wondering if there might be any other suggestions on how to clear and rebuild my USB device list. I've tried all of the above and still have been unable to.

Thanks!
0
sarabandeCommented:
i have some doubts that your drivers and usb is clean and up-to-date. can you install a clean windows 7 in a vm and check whether you get the same issues with the mouse?

if the issues don't show up in a clean system, you might consider to upgrade to windows 10 what also should solve the issue. or you use the clean system to go on?

Sara
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Peripherals

From novice to tech pro — start learning today.