Server 2012 and Office 2010 - thru RDC

Here's the issue.  I have 1 DC running Server 2012 R2 Standard and 1 RDS Server running 2012 R2 Standard.  Office 2010 Professional Plus is installed on the RDS Server.  Up until today, workers were able to remote into the RDS server thru RDC and use Office 2010.  We use folder redirection so that they have access to all of their folders/files.  No issues there.  However, when they now try to open a word doc it starts the Windows Installer service, which then tries to configure Microsoft Office Professional Plus 2010.  It then errors out with the following:  "Error 1317.  Setup cannot create the folder C:\Program Files\Microsoft Office\Office 14.  Verify that the path exists in your system and that you have sufficient permissions to update it."   I tried logging in as Administrator as well as a regular user, and get the same message.  No updates were installed on the RDS server.  The DC server did have some updates installed over night.  But I can't see how that would affect the Microsoft Office software.  All other programs (Adobe, LexisNexis, etc..) work fine.  It's just the Office applications.  I tried to do a "repair", but that errors out too with the same error message.  It won't even let me uninstall it. (same error message)  Any help would be Greatly appreciated!
ScreenHunter-133-Jul.-16-16.45.jpg
Voltron5Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Voltron5Author Commented:
I just tried that (thank you) and no change.  Same error message.
Wayne88Commented:
Microsoft Office 2010 Professional Plus configures each time you start

https://support.microsoft.com/en-us/kb/2528748
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Voltron5Author Commented:
That method does not pertain to Server 2012.
Robin CMSenior Security and Infrastructure EngineerCommented:
Check your permissions. SYSTEM account needs access to (basically) everything.
Different product, same error: https://support.microsoft.com/en-us/kb/872903
Same product, same error, same resolution: http://answers.microsoft.com/en-us/office/forum/office_2010-office_install/microsoft-office-2010-professional-plus/020841e9-9a22-45bf-9c06-ee8768cc6cf9?auth=1
Voltron5Author Commented:
I checked the System settings according to the article.  The System account has full permissions.  I did check the Microsoft Office Folder.  It wouldn't let me in. (You don't have permission to access this folder) So, I went under the Security Tab/Advanced, the Owner is listed as:  Unable to display current owner.  I added Administrator and it got me thru to the next set of folders, where I was denied permissions again.  I don't think I should have to do the same to every folder/file...
Voltron5Author Commented:
It won't let me Uninstall or Change(repair)  Office thru the Programs/Features.  I even tried the repair by running the installation again.  Comes out with the same Error message.
Wayne88Commented:
Hi Voltron5, that's not manual uninstallation.  The included video will show you how.

Please do this using administrator privileges (use admin account):

https://www.youtube.com/watch?v=usY86TlsoF8

https://support.office.com/en-us/article/Uninstall-or-remove-Office-2010-90635a1d-aec8-4653-b358-67e1b766fc4d?ui=en-US&rs=en-US&ad=US

If you can, please restart after manual uninstallation then try reinstalling Office again.  I wouldn't reinstall before a system restart.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Voltron5Author Commented:
Wayne88:  You the Man!  I followed the youtube instructions and it worked as far as uninstalling the program.  The only thing that I will add to it, is that I had to rename the Microsoft Office Folder so that the new installation would create a new one. (couldn't delete it)  It gave me an error code 1303 when I attempted to install it the first time.  After changing it, it installed and I was able to run the programs thru RDC.  Thank you VERY much for your support!  

RobinCM:  Thank you also for the suggestions!
Wayne88Commented:
Hi Voltron5, I am glad I can help.  RobinCM is right that when a folder cannot be deleted it's because of the permission issue.

When the server is not busy, you can go into safe mode and take ownership of the folder in question.  Uncheck the folder option to inherit permission from parents.  Once that setting is applied then set full permission to local the administrator account for that folder and child folders.  Then you should be able to delete it.
Robin CMSenior Security and Infrastructure EngineerCommented:
Too late now (I was asleep) but you can force a change of ownership with takeown.exe (built in to Windows). You can also force administrator access to files (without breaking other permissions or taking ownership) with the old admnalow.exe utility (which you'll have to download).

Anyway you're sorted, which is the main thing. I wonder what broke it in the first place?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.