Umbraco Website contact form not working after migration

Hi There,

We have migrated an umbraco website to GoDaddy shared hosting. After migration everything seems to be working as expected apart from the contact form.
When we fill out the contact form and press send, we receive attached .NET error.
We have even changed the STMP relay server on the web.config file to Godaddy's internal SMTP relay server but still the same error.

Please do let us know what we can try next to get this fixed.

Regards,
Robin
Screen-Shot-2015-07-16-at-23.12.53.png
RobKanjAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Randy DownsOWNERCommented:
Maybe this will help.

it works if I write this on the template and the form behaves correctly:

@Html.Action("RenderContactForm","ContactUs")

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RobKanjAuthor Commented:
Hi Randy

thank you and implemented but not working yet. As we are inexperienced in this I have offloaded this to developers who should be able to support it.
will revert.
Randy DownsOWNERCommented:
OK I am assuming you no longer need help since you offloaded the project to developers.
Learn SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

RobKanjAuthor Commented:
Thanks Randy. May I keep the question open as the developers I know are schooled in PHP and mySQL and they don't know Umbraco so well.

Also as you know, it's sitting on ASP and Dot Net and again I'm hoping they can troubleshoot to a degree although they have been realistic on their expectations.

Best wishes
Rob
Randy DownsOWNERCommented:
That's fine, let us know if you need help.
RobKanjAuthor Commented:
the link definitely helped and so much appreciation for that
The "Controller" and "Model" folders were corrupted and missing files. Recreated by developers and all good.
Thanks you.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.