Restore Drupal Website from CPanel Full Backup

Hi everyone -

I'm both perplexed and frustrated.  I have TWO websites both are Drupal and both are based on Acquia distributions.  The websites are quite separate in terms of hosting, although both are hosted by the same provider (managed as 2 separate subscriptions).

Website 1 WORKS - I can log into cPanel and create a FullBackUp.  I download the backup to my local machine and unzip the .gz and .tar in 2 stages using 7-zip.  I use Acquia Dev Desktop 2 to run the backup website.  I navigate to Backup...\public_html for the website and use the option to use an existing SQL db which I find in  a folder called mysql.  After my dino-PC churns away for a short while my website appears.

Website 2 FAILS - I do everything the same but... After my dino-PC churns away for a short while I see the new website setup wizard.  I'm at a loss as to what the causal difference is.

I've tried several things, including repeating entire process on multiple PCs but website 1 always restores and website 2 always gives me the setup wizard.  Website 2 is due (overdue, perhaps) for a security update and other than that it works perfectly so I am reluctant to change the live version until I have at least verified the update on my desktop.

Any help much appreciated!
LVL 15
DrTribosAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lenamtlCommented:
Your hosting company should help you with that, did you open a ticket to request help?

You can check for error message into the error log.

Both servers can have different settings and configuration.
0
DrTribosAuthor Commented:
Hi Thank you for your thoughts.  

I don't think it is a hosting issue.  After posting my question I found out that I am able to make a clone of my problematic website in a sub-domain.  FWIW this was the first time I've used a sub-domain...  (total noob)

The reason I was trying to restore a backup on Acquia Dev Desktop (not related to my hosting company, VentraIP) is because I wanted a backup somewhere *safe* in case I accidentally did:
SSH: rm -rf *

Open in new window

from the wrong directory...  As it is my understanding that to update drupal core requires all drupal related directories and files (except sites & user configured) to be deleted and replaced with files from the update...

The only differences that I could detect between the two websites were that the problematic website server:
- was using a later version of php
- was using additional php extensions required by some modules
- had different timeouts

However - I'm a novice at this and don't really know what to look for.

In fact I am such a novice that, I accidentally deleted the problematic website (files & dirs) from the server before I make my clone... thus my hand was ultimately forced and I am happy to report that I was able to restore the LIVE website from the back up of the 'sites' folder that was on my PC...

Having achieved that (minor miracle) I have not yet had the chance to attempt to backup & restore the updated (Drupal core) version of the problematic website to my PC using Acquia DD2.  

I also ended up installing the Backup & Migrate module to the problematic website in an attempt to create a *different* backup (in case there was a problem with the backup, 7-zip appeared to be stalling using the cPanel backups).  The Backup & Migrate backup was much smaller and I don't think 7-zip stalled during extraction... but I got the same end result... Acquia DD2 created a new website instead of restoring my website.

I'm still at a loss as to how do get my website working on my PC - might try WAMP...?

Other suggestions?

Cheers,
0
lenamtlCommented:
PHP and MySQL version can make a huge difference when not the same version from a server to another.

If you have a working backup let say it's work ok on your PC using Wampserver
and it is not working online, this will be a server configuration issue.

Check what are the requirement for your Drupal Version, compare it with your online server settings, extensions and version then if it's still not working you will need to change the server settings and your hosting company can help you with that.
Make sure you upload the Database correctly and have the correct connexion information.
Most of hosting company allow custom settings and custom PHP version using a custom php.ini for example.

Corrupt backup could be the culprit too something went wrong during the backup procedure.
This can be delay, data and files qty and size to name a few...
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

DrTribosAuthor Commented:
Hi thank you for your comments.  

The website that I am unable to restore on my desktop is smaller and simpler than the website that I can restore.  Therefore I think:
- issue is not related to corrupt backup

I've not had a chance to look into WAMP, BUT... I'd prefer to use the Acquia tool set.  So if the version of PHP could make such a difference then I think the solution to my issue involves adding the missing php modules to Acquia Dev Desktop 2; I'll see if I can find out how to do that - I already tried to figure out how to add the MS SQLSRV dll to Acquia but couldn't quite grasp which files to use and where they needed to go...

BTW the reason the PHP version on the host server is different is because I changed it; and the reason I changed it is because I wanted install a module that required this version of PHP and the additional modules...

I believe my backup is good - I just lack the ability to get it working on my PC.  Any guidance on how to setup Acquia DD2 would be much appreciated :-)

Cheers,
0
lenamtlCommented:
Hi,

You will find the docs: https://docs.acquia.com/dev-desktop2
You will need to connect to your account to read the help file, I do not have an account and they have issue on their website at the moment. They have also known issue section that can help you with the troubleshooting.

I have found some tutorials:
http://it.umn.edu/setting-drupal-local-environment-using
http://drupal.stackexchange.com/questions/51449/how-to-import-a-live-drupal-site-into-acquia-drupal-dev-desktop

You can also check on Drupal forum, other user may have similare issue
https://www.drupal.org/node/2320969
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DrTribosAuthor Commented:
Thank you so much - I'll take a look and get back to you.  Cheers,
0
DrTribosAuthor Commented:
Sorry that I have taken so long to get back to you... ultimately I created my backup on the server and that worked so the pressure was off.  Your last comment had a ton of great stuff, thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Drupal

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.