Problem making CNAME work with Amazon Cloudfront CDN

I am exactly following Amazon's instructions to get a CNAME record to point to my CloudFront distribution (video streaming), but all I get is "The connection was reset" or "No data received."  from Chrome.  Here are my Amazon settings:

S3 Bucket Name: six-sigma-tutorials
(bucket has subfolders that contain MP4 H.264 files)
Sample File from Bucket
file: six-sigma-tutorials/black-belt/green belt review.mp4
link:http://s3.amazonaws.com/six-sigma-tutorials/black-belt/green+belt+review.mp4
storage class: Standard
server side encryption: none
permissions:  Everyone, 'open/download'

CloudFront Distribution Settings
delivery method: RTMP
distribution status: deployed
state: enabled
origin: six-sigma-tutorials.s3.amazonaws.com
domain name: s29r4mbh2gwab5.cloudfront.net
origin access identity: -
alternate domain names (CNAME):
 videos.six-sigma-training.qsigmagroup.com
 videos.six-sigma-certification.qsigmagroup.com

DNS Settings
In GoDaddy, in the DNS Settings for "qsigmagroup.com", I have a CNAME entry "videos.six-sigma-training" that points to "s29r4mbh2gwab5.cloudfront.net"

The Amazon link to the file (above) works just fine, but CNAME link to the file leads a page that says "The connection was reset"

I have tried the following links:

http://videos.six-sigma-training.qsigmagroup.com/six-sigma-tutorials/black-belt/green+belt+review.mp4
and also tried:
http://videos.six-sigma-training.qsigmagroup.com/black-belt/green+belt+review.mp4

In Amazon, permissions on the file and the folder that contains the file are `Everyone, open/download`.

Note: Using a different URL, I also tried this using Amazon Route 53 as the DNS server.  The result was the same.

Any help would be appreciated.
LVL 1
stgreenwaltAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
This is not a problem with the CNAME record or DNS in general, they seem to work fine, if you use another protocol in front of the url the url actually works.

rtmp://videos.six-sigma-training.qsigmagroup.com/black-belt/green+belt+review.mp4

You actually have this setting in your Cloudfront Distribution Settings by the way

Now I don't know what this means for your setup, maybe there's more info to get here or here, also check out the Post Streaming Distribution...
0
Shalom CarmelCTOCommented:
You don't open an RTMP stream with chrome. The HTML5 video player needs access via HTTP.
Create another Cloudfront distribution for the same bucket, and point your CNAME to it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
AWS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.