Resource-Exhaustion-Detector Event 2004 on Server 2008R2

I am helping a client with a software upgrade on their server. One of the updates failed and when I tried to re-install it I got an error that the C drive was full. I decided to move the page file to the D drive to free up space - I originally configured it with 800 MB on the C drive and System Managed on the D drive. I did not know it until later today, but that triggered regular Resource-Exhaustion-Detector Event 2004 errors in the System log:

Windows successfully diagnosed a low virtual memory condition. The following programs consumed the most virtual memory: sqlservr.exe (3016) consumed 749858816 bytes, dns.exe (2140) consumed 247664640 bytes, and dsm_om_connsvc64.exe (4860) consumed 220897280 bytes.

It is always the same 3 programs, but none are using a significant amount of space. I have tried moving the page file back to C, making it system managed, static size, and specified range. I have set it to have no page file, deleted the page file, then re-created it more than once. Currently (after deleting the page file), it is set to 800 MB on the C drive and 32-48 GB on the D drive - and I have verified the size and presence of the page files using SpaceSniffer. The server has 32 GB of RAM and 4 x 100 GB SSD in Raid 5. It is used for AD, SQL 2008, and file server.

How can I resolve the issue without re-installing Windows?

Thanks in advance
fisher_kingAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Robin CMSenior Security and Infrastructure EngineerCommented:
Robin CMSenior Security and Infrastructure EngineerCommented:
Also, set the maximum server memory for SQL server if you've not already done so. Otherwise SQL will eat pretty much all your RAM.
You can also run Process Explorer to see more detail about the amount memory that's being used.

Also see http://jongurgul.com/blog/sql-server-memory-reporting-setting-incorrectly/
And https://channel9.msdn.com/Shows/Data-Exposed/7-Ways-Your-Server-is-Lying-To-You
fisher_kingAuthor Commented:
The issue was caused by a corruption in SQL server. I disabled all non-MS services in MSCONFIG, but the problem continued - Commit % would steadily climb to 100% and cause the server to crash. When I stopped the SQL Server service, Commit % would drop to 10%. I uninstalled SQL and re-installed it and it is now working properly. Thanks for your help.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
fisher_kingAuthor Commented:
I used process monitor, but it did not reveal SQL to be using all the virtual memory - it was only by disabling the service that I discovered the cause.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.