WindowsServer2008 R2 iSCSI volumes not mounting after reboot

We've had two iSCSI targets, a SCALE device and a Drobo, attached to a Windows Server 2008R2 and mounted as drives for a while.
Once or twice in the past, the volumes disappeared, perhaps after WindowsSecurity Updates were applied. Disconnecting the targets from iSCSI Initiator, then rebooting the machine seemed to fix things; the volumes would reappear with previously assigned drive letter, and operations would resume.
The volumes\attached drive letters disappeared from the server yesterday, presumably after Windows Security Updates were applied. Unfortunately, they did not reappear after disconnecting them from the iSCSI Initiator, and a server reboot.
The targets appear in the iSCSI Initiator window as "Connected", but the volumes will not mount.
In Drobo Dashboard, the volume appears as mounted, but we are not able to assign it as a drive letter.
We tried one of the suggested resolutions on this site to make the Server service dependent on the iSCSI service, but that did not seem to work. Thanks in advance for any assistance you might be able to provide.
eimonkeyAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

eimonkeyAuthor Commented:
*** UPDATE *** So, we were able to get the Drobo drive to reappear after deleting all items from the iSCSI Favorite Targets list, unmounting the Drobo volume from the Drobo Dashboard, and rebooting.
Unfortunately, the SCALE target appeared as "Disconnected". We are going to reconnect, reboot, & hope it decides to join us again.
eimonkeyAuthor Commented:
SCALE target still not mounting. Researching & contacting SCALE support. Is there any way to similarly "unmount" the SCALE target from Windows and start fresh? We tried to remove\readd the server IP from the SCALE dashboard, but that did not seem to work.
eimonkeyAuthor Commented:
A SCALE firmware update resolved the issue. We were able to connect & initialize\put the disk online in Disk Manager on the Windows Server. Thanks for playing!

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.