Delayed emails in Exchange

This just started happening yesterday on our Exchange server (version 2010). I noticed some emails stuck in the queue with an error message 400 4.4.7 message delayed. To an external user I can possibly understand why but these are internal emails within the company from one user to another user.

For example, this is just an alert that comes from Ping Plotter.

Identity: CTEXCH01\99073\13693744
Subject: PingPlotter Auto-Alert! Latency Over 400ms Detected!
Internet Message ID: <c642cbe3-fdcc-409b-9055-96e6b25b0c2e@CTEXCH01.ctitle.local>
From Address: noreply@cxxxx.com
Status: Ready
Size (KB): 2
Message Source Name: SMTP:AllowedtoRelay
Source IP: 10.1.1.11
SCL: 0
Date Received: 7/17/2015 5:21:17 AM
Expiration Time: 7/19/2015 5:21:17 AM
Last Error: 400 4.4.7 Message delayed
Queue ID: CTEXCH01\99073
Recipients:  jxxxx@cxxxxx.com

Another example
Identity: CTEXCH01\99073\13693964
Subject: xxxxxxx
Internet Message ID: <99EF42C991E1294F9257BAD247946C1AC8209B@CTEXCH02.ctitle.local>
From Address: lxxxxx@cxxxxx.com
Status: Ready
Size (KB): 2458
Message Source Name: FromLocal
Source IP: 255.255.255.255
SCL: -1
Date Received: 7/17/2015 9:27:16 AM
Expiration Time: 7/19/2015 9:27:16 AM
Last Error:
Queue ID: CTEXCH01\99073
Recipients:  jxxxxx@cxxxxx.com

Other emails I am seeing in there from 3 hours ago yet there is no last error on them. Our exchange is a few years behind on updates but we are forbidden to upgrade it at the moment via management. Otherwise I'm not sure what is causing this.
LVL 2
stlhostAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Wayne88Commented:
Run the Microsoft's Exchange Best Practices Analyzer.  It can give you clues to the problem.
0
stlhostAuthor Commented:
Thanks, but it didn't offer me any clues to what could be wrong. Actually didnt show any issues
0
stlhostAuthor Commented:
Turned out to be a bad DNS entry
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stlhostAuthor Commented:
bad dns entry
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.