Logical Drive not visible in Windows Explorer on Server 2012 R2

Windows Server 2012 R2
1TB HDD with 3 Primary Partitions and the 4th slot an Extended Partition divided into the following Logical Drives:
P: - 40GB
Q: - 12GB
R: - 12GB
S: - 12GB
T: - 100GB
U: - 60GB
V: - 240GB
W: - 160GB
Free Space - 150GB +/-

All the Logical Drives show in Windows Explorer, with the exception of T: - T: is not visible. A share in T: does successfully map as a network drive (probable red herring). Shares in T: are visible by browsing the Network Shares.

All the information in T: is accessible in Windows Explorer by typing T: in the address bar.
ChkDsk doesn't reveal any physical problems.
The Administrator account I am using can see all other drives.
Security permissions appear to be the same for T: as all other drives (Full Control by Security Group and also explicitly by Admin account name)
T: is visible in Disk Management, just not on the left side under This PC in Windows Explorer.
We have restarted multiple times, turned off, unplugged, cleared capacitors, waited, etc.
T: is 90% full before moving the data off and reformatting. After reformatting the Logical Drive, the drive does not show even with 0 data on it. Adding sample data does not help.

I moved the data off T: and reformatted the Logical Drive using Z: as the selected drive letter (same space, just a new format and drive letter). Restarted. Still doesn't show up, even though S: and U: on either side (as well as all other drives) are visible.

Only the Default Domain Policy that is standard out of the box for Microsoft is applied or even enabled at this point (I took them all off to make sure).

I was unable to Google anything that even seemed to address the problem (Logical Drive not showing in Windows Explorer and various other combinations).

I have not personally seen this problem before and before I move all my data off the drive and start over, I am hoping for a solution. I have a lot of time in the various shares and permission sets and I am guessing it is something simple :)
LVL 1
pandafusionAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Snowbella KilangitCommented:
Are you using GP to map or script?
Try manually mapping T
0
David Johnson, CD, MVPOwnerCommented:
It is a local drive not a network drive so mapping is not an issue. What you can do is from diskmgmt.msc remove and re-add the drive letter.. now from taskmgr kill all explorer processes and now from taskmgr file run explorer.exe
0
David Johnson, CD, MVPOwnerCommented:
another item is remove the check mark on hide empty drives in folder optionsuncheck this
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

noxchoGlobal Support CoordinatorCommented:
Instead of reformatting it - delete T: partition and recreate it.
0
Snowbella KilangitCommented:
In diskmgmt,Exe try mount the drive by changing the drive letter to a free one and see if it appears. Then remove and mount again using T
0
dbruntonCommented:
Is it possible that the NoDrives option has been set for T: in Windows Explorer?

See http://www.askvg.com/all-kinds-of-restrictions-for-windows-2000-xp-2003-and-vista/ and the Numbered paragraph 25.  Read the whole paragraph carefully and check the registry and see if that option(s) has been set.
0
pandafusionAuthor Commented:
Thank you all for the posts.

Snowbella – for your first post: as noted by David Johnson, this is a local login issue and not a network mapping issue.
Noxcho - to clarify my original post, I already deleted T:, then recreated it with a new format and a new drive letter, albeit in the same 'space' previously occupied.
Dbrunton – good thought. However, I have disabled all group policy and the Explorer folder does not exist under Policies in the registry until the appropriate Group Policy is implemented.
https://technet.microsoft.com/en-us/library/Cc938267.aspx
David Johnson - For your second post, 'Hide Empty Drives' was not marked. For your first post, it sounded like the deletion and recreation would be similar/have fixed the issue, but I did as you suggested exactly: I removed the letter entirely. I re-added the letter. I started task manager and killed all explorer processes. I the restarted explorer.exe from task manager. Unfortunately, this did not work.

I have potentially important new information:
The issue persists in both an RDP and a Console session.
I copied the existing admin account in ADUC, and the new account TestAdmin can see the T: drive.
-      This obviously appears to indicate an account specific issue
-      The copied account has all the group memberships of the original
-      I immediately went back and double-checked all NTFS permissions on T: and its subfolders. There are no deny permissions and, in fact, Everyone has Read & execute.
-      Removing all NTFS permissions entries for the original Admin account name and restarting, reformatting/creating T:, etc. yields no change in behavior.
-      This, obviously, strongly suggests that the original Admin account itself is at issue (though I am uncertain what would cause such a very specific issue like hiding the T: drive.)
I now have a workaround, but would still pay points to anyone who can help me figure out how to diagnose and fix this issue.
0
Snowbella KilangitCommented:
Try login as admin, rename current user profile (Userx)
Then login as User to create new profile
Interested to know results...
0
pandafusionAuthor Commented:
Hello Snowbella,

Good thought. I renamed the original Admin folder in C:\Users. When I subsequently logged in as the original Admin, it created a temporary profile. Within that temporary profile, I could see the T: Drive as desired.
I am now considering signing in as TempAdmin to do the following:
1. Delete the original Admin user folder in C:\Users
2. Open regedit and navigate to:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
3. Locate the original Admin SID and delete it.
4. Log back in as the original Admin in order to recreate the new user profile. NTFS and other ACL issues do not arise because the original Admin account will be assigned its original SID.

Is this the best way forward? Is there anything I have not properly taken into account?
Thank you!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Snowbella KilangitCommented:
Check, note down, save or backup anything that's important in the current admin profile. Then delete And recreate the profile as you have outlined.
0
pandafusionAuthor Commented:
My original testing in my first response to my original post indicated that the User profile was at issue.
Snowbella assisted with a nice insight/methodology for testing by creating a temporary profile through renaming the User folder.
My follow-up contained the specific steps and registry location. Therefore, I marked it as best solution.
Snowbella gets points but my posts are relevant to anyone looking to fix a similar issue in the future.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.