Exchange 2010 cannot create send or receive connectors "You must provide an value for this property"

I have Exchange 2010 SP3 on a Windows 2012.  I've tried a few instances of this install on my test domain so I can work out the install however I'm trying to create a simple Send SMTP internet connector and no matter if I use the EMC or powershell cmdlet the response is "you must provide a value for this property".  Same thing happens when I try to create a receive connector.  I cannot find a good article to help me fix this.  

You must provide a value for this property.
    + CategoryInfo          : NotSpecified: (0:Int32) [New-SendConnector], DataValidationException
    + FullyQualifiedErrorId : 94A3BE3B,Microsoft.Exchange.Management.SystemConfigurationTasks.NewSendConnector
    + PSComputerName        : server.FQDN.net
Joe GIT personalAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
Is the MS Exchange Transport service present and running?
Being unable to create either kind of connector is unusual, I would therefore be suspecting a bad installation.

Also - this is Windows 2012 and not 2012 R2?

Simon.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Joe GIT personalAuthor Commented:
it is Windows 2012 R2 and yes the ms exchange is running.  

I was installing it again on the same domain.  In the start of the 2nd install I had to edit the adsi a few times to get it going.  The first was at install it was asking to go into recover mode since there was another instance and I had to delete a offline address book.  

Since it may be possible its a bad install.  Should I completely remove the exchange? - is that possible and start again?
Joe GIT personalAuthor Commented:
I can't even remove it in maintenance mode.  Same error.  "provide value".
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Joe GIT personalAuthor Commented:
My constant reinstalls and testing drew up a bad install.  I'm doing it from scratch with a clean domain/exchange environment.
Simon Butler (Sembee)ConsultantCommented:
"Windows 2012 R2 "

That isn't a supported OS for Exchange 2010, which is probably a lot of your problems.
Windows 2012 is the latest version you can go to.

Download Exchange 2010 SP3 and the latest rollup. Put the rollup in the Updates directory and it will be installed a the same time.

Simon.
Joe GIT personalAuthor Commented:
I'm going to use Windows 2008R2 then.  thank you
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.