Avatar of thenelson
thenelson
 asked on

windows 7 task bar icon and connection in connection list shows red X but I am connected to internet

As shown below my task bar icon and the connection in the connection list almost always shows a red X but I can still access the internet and other computers. This happens with all three of the computers on the network. If I unplug the router for a few minutes and plug it back in, the displays are normal but then go back to the red X after a few minutes. As can see in the images, hovering over the connection and the top of the connection list shows that the connection is fine but when I click on the connection, it shows the settings on the computer do not . My router is a D-link DIR-601. I am using WPA2 mode. Any ideas?Red X view 1Red X view 2Computer network properties 3 router settings
Windows 7RoutersNetworking

Avatar of undefined
Last Comment
John

8/22/2022 - Mon
John

Disable your antivirus temporarily and see if it makes a difference. I had Symantec (prior version) causing a like issue with my Windows 8.1 machine. New antivirus version fixed it.
ASKER CERTIFIED SOLUTION
John

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
Jonathan Pringle

Have you updated your wireless drivers?
thenelson

ASKER
I did disable the antivirus but it did not help.
Thanks for the suggestion.
Your help has saved me hundreds of hours of internet surfing.
fblack61
John

Did you try the two suggestions of deleting and remaking the wireless profile and checking for an updated wireless driver?
thenelson

ASKER
I just had Windows check for wireless driver updates but it said I have the latest.
How do I delete the wireless profile?
Predrag Jovic

Delete wireless profile:
Open network and sharing center - manage wireless networks - select network -  right click and delete

I guess that if you choose just one WPA or WPA2 (not both) wireless encryption could solve problem. But do that before recreate wireless profile.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
thenelson

ASKER
"I guess that if you choose just one WPA or WPA2 (not both) wireless encryption could solve problem. But do that before recreate wireless profile."
What do you mean?
Predrag Jovic

Choose
Setup router - from drop down menu you can choose WPA only or WPA2 only.
Then delete network on host, and join to wirelles again.
thenelson

ASKER
The router was originally set for WPA2 only mode. I changed it today to see if it would make a difference - it didn't. WPA only is not an option.
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
thenelson

ASKER
I deleted the wireless profile; swapped out the router and recreated the profile. So far, so good.
The new profile shows JaneNelson 3. Is there a way to completely delete the old profiles so it only shows JaneNelson without the "3"?
John

To delete profiles, open cmd.exe with Run as Administrator and type

netsh wlan delete profile name="Profile Name"  

Do this for all profiles you do not want.

When done, don't worry if your active profile has a number, so long as it works.
thenelson

ASKER
After swapping out the modem, deleting and rebuilding the connection has been solid.
Thanks
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
John

@thenelson  - Thanks and I was happy to help.