Anyway to bypass Captcha when using Coldfusion CFmail On Yahoo Mail?

We need to temporarily set up mail on a Yahoo account using cfmail so that our users on the website can send us mail. I understand we can use a form to save to our database and might need to do that but this is just temporary and wanted a quick fix to Yahoo while we work on getting our mail servers set up.

All works fine when sending from GMAIL to YAHOO test accounts, directly, there's no Captcha  question, "To show that you are human .."

I've used different ports for yahoo mail and those I did you, including 25 and 465, were accepted by YAHOO and I made certain I set to "Verify mail server connection" in ColdFusion's CF ADMIN.

But sending using CFMAIL does not prompt the user for the Captcha roadblock question on YAHOO. The person using CFMAIL does not see it. My setting in CF Admin for mail is correct. I tested it.

Is there some setting I'm missing, someway around this?
Grover McBroomAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

_agx_Commented:
What makes you think it is a captcha problem?  

A) It sounds like you are trying to do relaying. If yes, are you sure it is supported? Not all mail servers allow this.

>  My setting in CF Admin for mail is correct. I tested it.

B) Does that mean the connection verified successfully?  If yes, what are your CF Admin settings and cfmail code (obviously obfuscate the username and password)?

C) Add some debugging to the cfmail call. What's the result in the log file? ie

                 <cfmail debug="yes"  ...>  ....</cfmail>

Important, debug=true

...  sends debugging output to standard output. By default, if the console window is unavailable, ColdFusion sends output to cf_root\runtime\logs\coldfusion-out.log on server configurations. On J2EE configurations, with JRun, the default location is jrun_home/logs/servername-out.log. Caution: If you set this option to yes, ColdFusion writes detailed debugging information to the log, including all message contents, and can generate large logs quickly.
Grover McBroomAuthor Commented:
The CF mail log file has the request from Yahoo, "To show that you are human .."

That's why I assume it's a Captcha  question and why the test mail was not relayed.

> A) It sounds like you are trying to do relaying. If yes, are you sure it is supported?

Not sure at all, can't seem to find any info on it so that's why I came here.
_agx_Commented:
What about the other questions? We need more details on what settings you're using.  

For example, are you using TLS or SSL?  Are you using the account owner as the "From" address, etc...   Also, it would help to see a snippet of the actual logs and error codes, rather than just a description of the message.

According to yahoo's help files these are the SMTP settings.  No idea if it they're still current.  Keep in mind, when it comes to relaying, it is always possible use is restricted or no longer supported.  

Outgoing Mail (SMTP) Server

    Server - smtp.mail.yahoo.com
    Port - 465 or 587
    Requires SSL - Yes
    Requires TLS - Yes (if available)
    Requires authentication - Yes

Open in new window


EDIT:
Side note, since you mentioned gmail - have you tried this with a gmail account? It's probably more widely used than yahoo, so there are bound to be more articles on using cfmail + gmail. I suspect you'd have better luck with it.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Grover McBroomAuthor Commented:
Here's the log file, minus what the xxx's overwrote. Obviously the parameters seem to be correct, connection settings, etc, just nowhere to see and answer the Captcha question.


type:  text/plain; charset=UTF-8
server:  smtp.mail.yahoo.com:995
server-username:  xxx@yahoo.com
server-password:  U3Vub2xpbmUxNDM=
usetls:  true
port:  995
from:  xxx@gmail.com
to:  xxx@yahoo.com
subject:  Reader Comment
X-Mailer:  Microsoft Office Outlook 12.0, Build 11.0.5510
Return-path:  xxx@oregonherald.com
X-Mailer:  Microsoft Office Outlook, Build 11.0.6341
MIME-Version:  1.0
Return-path:  xxx@yahoo.com
X-Mailer:  Microsoft Office Outlook, Build 11.0.6341
MIME-Version:  1.0
body:  Grover
body:  To show that you are human and not a spam bot, please answer this question:To show that you are human and not a spam bot, please answer this question:To show that you are human and not a spam bot, please answer this question:
body:  
body:  To show that you are human and not a spam bot, please answer this question:
body:  
body:  To show that you are human and not a spam bot, please answer this question:
body:

I tried this and other settings, but the settings I currently have work. It's just the that Captcha is not answered or seen. If you need more than what's here, just ask.


Outgoing Mail (SMTP) Server

    Server - smtp.mail.yahoo.com
    Port - 465 or 587
    Requires SSL - Yes
    Requires TLS - Yes (if available)
    Requires authentication - Yes

>  have you tried this with gmail account ...?

Just sending, not receiving. I'd rather exhaused this first, then I'll be on my way for other mail services to test.
_agx_Commented:
> from:  xxx@gmail.com

It could be due to using a different address/domain for "from".   Did you try it with your yahoo email first?  These instructions for gmail worked fine for me with smtp.mail.yahoo.com. It just required a change of smtp server and credentials:

Try sending a test email to/from your yahoo address first.  Get that working, then try different combinations.

Port 465/SSL=true

<cfset mailAttributes = {
    server="smtp.mail.yahoo.com",
    username="yourEmail@yahoo.com",
    password="your_password",
    from="yourEmail@yahoo.com",
    to="yourEmail@yahoo.com",
    subject="Test mail port 465, SSL enabled"
}
/>

<cfmail port="465" 
   useSSL="true"
   debug="true"
   attributeCollection="#mailAttributes#"
   >port 465, SSL enabled</cfmail>

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Grover McBroomAuthor Commented:
Sorry for the delay, was called out of town. Thanks for all the help. I'm sure I can use this next time. For now we purchase the Icewarp email server for  local email.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ColdFusion Language

From novice to tech pro — start learning today.