Citrix IMA service not able to connect to the database

I changed the domain admin password and I think its tied into the ODBC database connection between our citrix servers and our citrix database. When I run the app center the autodiscovery fails, in the event viewer I see the error it states "Citrix XenApp failed to connect to the data store, ODBC error while connection to the database."
I went through the ODBC connections and I don't see one for this, I looked in admin tools and in c:\windows\syswow64 because this is a x64 server but I don't see a connection for it. Where can I find this connection so I can change the creds and get this working?
bankadminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Carl WebsterCommented:
This is from memory, look in c:\program files(x86)\citrix\independent management architecture for a mf20.dsn file. That is the dsn file you need to be looking at. The password is changed with the dsmaint utility.

What version of XenApp?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bankadminAuthor Commented:
6.5
0
bankadminAuthor Commented:
Good memory I found it. However I don't see a field to enter a password it does have a UID and that is the administrator account but no password feild
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

bankadminAuthor Commented:
Im unable to get it to work Im not sure what Im doing wrong. I stop the IMA service, open command prompt then navigate to the location of the mf20.dsn and run this command
dsmaint config /user:domain\username /pwd:password /dsn:"C:\Program Files (x86)\Citrix\Independent Management Architecture\mf20.dsn"
I get this error: failed to connect to the data store. This setting will be reverted back to previous setting
Unable to change configuration settings
Please verify parameters and data source

Do you see anything Im doing wrong?
0
Carl WebsterCommented:
how many xenapp servers?
0
bankadminAuthor Commented:
5 servers
0
Carl WebsterCommented:
on one, go to services.msc, sort on the logon as column, change the passwords for every service that uses the old account, restart those services, now run the command.
0
bankadminAuthor Commented:
None of the services use the account in question
0
Carl WebsterCommented:
your database for the data store, does that account have permissions to the db now?
0
bankadminAuthor Commented:
It did not so I added it as a valid logon to the DB I gave the account all the permissions I could. I can logon to the DB from the server with that user account now but when I run the command on the citrix server I still get the same errors (I did shut down the IMA service before running the command on the citrix server).
0
bankadminAuthor Commented:
I got it I had the command written in notepad so I didn't have to retype and I had the password in there wrong. Thanks for the help
0
Carl WebsterCommented:
The account you are logged in with and running the dsmaint command, is it a full farm administrator? If not, run the command logged in as a user who is a full farm administrator.
0
Carl WebsterCommented:
Great, glad you got it resolved. Do the exact same process on the other 4 servers.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Citrix

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.