Link to home
Start Free TrialLog in
Avatar of Jim Metcalf
Jim MetcalfFlag for United States of America

asked on

Trying to move master.mdf file but sql service won't start after move

I am almost positive I am using the correct procedure to move the master database
http://basitaalishan.com/2012/07/29/how-to-move-master-and-resource-database/

I am able to move it deeper in the file directory location where it currently is just to make the procedure work.  What I can't do is get the service to start after I move the master.mdf file and ldf  files to a location outside of the current folder.  I can make this work in subfolders of the current folder.

in the security properties of the folder that works I see a user MSSQLSERVER that has full rights to the default folder.
in the folder I am trying to move the master.mdf, I do not see MSSQLSERVER.  I also can not add it.  Can someone explain how to correct this.  I am almost positive this is the problem
mast-file-location.jpg
Avatar of Kyle Abrahams, PMP
Kyle Abrahams, PMP
Flag of United States of America image

Are you logged in as an administrator on the local box?  
Confirm MSSQLServer is the account that's actually running the service?

You might want to try creating another local account, assigning permissions to that account in the new folder, and then changing the service that the account runs under.

The question is why can't you add the MSSQLServer as a permission to the new folder, you need to resolve that first.
Avatar of Jim Metcalf

ASKER

Ok I am more jacked up now.   I am trying to revert back to the username and password for the service account shown in the screenshot.  I don't know the password.  how to manage the password for the nt service/mssqlserver  account.
anyone know/
Leave it blank, it should be auto populated.
VOILA
now im back to square one.  I think I'm missing something probably pretty easy.  I have run into this before.  I added an administrator account to start the sql service but trying to start the sql instance with the new master file location failed.

is there someplace within sql management studio to identify folders that sql accounts should have access to.....
it's not within management studio . . . you do that in the windows explorer.
does this screenshot help?
sorry here it is
2.jpg
The question is why you can't.  

If you click edit -> add ->

First change your locations to be the machine name (rather than a domain [assuming you're attached to one])

Then do advanced -> find now . . . see if MSSQLServer is listed or anything like it.
can't find it.... not from the local host.  not from different types.   notta
ASKER CERTIFIED SOLUTION
Avatar of Kyle Abrahams, PMP
Kyle Abrahams, PMP
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial
tried. it...i can't find that account anywhere and when i try to select it from the user list i can't find it either.  tried local, domain, all 3 types..
Kyle-
thanks for working with me.  You lead me down the right path.
eventually i gave the folder on my host read/write access to the user everyone
that fixed it