Exchange 2010: Expired Certificate Still being used

hello

I am getting error id 24 in MSExchange Web Services on my Exchange 2010 SP3 server - says certificate expired. That certificate has expired but I renewed it and imported the new one and assigned all the services (except unified messaging which we don't use) to it.

Questions:
a) am OK to delete the old certificate?
b) why is it still being used for exchange Web Services (assume autodiscover and owa) when it does not have the IIS service role added to it?
dejectedAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Muhammad MullaCommented:
Did you use powershell, Enable-ExchageCertificate for all the services you're using?

You can remove the old one with Remove-ExchangeCertificate -Thumbprint "xxxx"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MAS (MVE)EE Solution GuideCommented:
Get-ExchangeCertificate | ft Subject,services,IsSelfSigned,NotAfter

Open in new window

Run the above command and make sure only valid certificates are there in server certificate store.
Make sure expired certificate is not there.
If it is there remove it by
Remove-ExchangeCertificate -Thumbprint D18B16C10075CDE2B09BA575AF

Open in new window

You will get the thumbprint by
Get-ExchangeCertificate | ft thumbprint,NotAfter

Open in new window


Enable services on the right certificate. You can change services based on your requirement.
 
Enable-ExchangeCertificate -Thumbprint <thumbprint> -Services IIS,SMTP,POP,IMAP

Open in new window

0
dejectedAuthor Commented:
Hello OfflineGeek

No - I did it through the EMC by  clicking "Assign Services to Certificate…" under the Actions pane. Is that not a good thing?

The old certificate is displaying as having SMTP, POP and IMAP assigned but not IIS - weird.

If I remove the old one will Exchange automagically use the new one for IIS?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Simon Butler (Sembee)ConsultantCommented:
If the certificate is not showing as being used for IIS, then you should remove it. Use remove-exchangecertificate to do that.
If Exchange then rejects that, saying you cannot remove the default SMTP certificate, simply run new-exchangecertificiate (no further options) and say yes to replace the default SMTP certificate. That will generate a new self signed certificate for internal SMTP use.
You can then remove the old certificate.

Don't forget to run iisreset afterwards.

Simon.
0
dejectedAuthor Commented:
Thanks all. So the general feeling is just use the exchange powershell to remove the certfiicate? And nothing bad will happen...?
0
Muhammad MullaCommented:
Yes, Exchange Shell is the best method of removing/enabling certificates.
0
dejectedAuthor Commented:
Thanks again - removed using the exchange powershell as advised. Cheers!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.