smtp misconfiguration?

Hello,

I just setup an exchange 2007 test mail server, I came across this website to run a smtp test on my mail server. I ran a test without providing any authentication credential which startled me. Can anyone tell me where in the configuration that i missed that will allow mail to send without authentication?

http://smtper.sweetylife.com/
lappladminAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Will SzymkowskiSenior Solution ArchitectCommented:
You need to check your receive connector permissions group. Make sure that Anonymous is NOT selected.

Will.
0
lappladminAuthor Commented:
If leaving this option unchecked will that impact any mail flow from the internet to me?
0
Will SzymkowskiSenior Solution ArchitectCommented:
No it will not it will not. Although I do not know your environment you can simply re-enable it if it does. However it should not affect anything,

Will.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Will SzymkowskiSenior Solution ArchitectCommented:
Second thought, it might affect internal application servers that are sending email notifications without using authentication. However from the INTERNET it do you have a smart host? If you do then it might affect that as well.

Best option is to create a new receive connector and lock it down via IP address under the networking tab and then allow anonymous permission group. It will be locked down via IP.

Do not do this on your DEFAULT receive  connector.

Will.
0
lappladminAuthor Commented:
1. I don't have a smart host.
2. that was my default receive connector.
0
Will SzymkowskiSenior Solution ArchitectCommented:
Well just remove the setting and see if anything happens. Preferably after hours.

Will.
0
lappladminAuthor Commented:
Will

I ran a test last night with that option unchecked, all mails flow from the internet rejected.
0
Will SzymkowskiSenior Solution ArchitectCommented:
What are you using as a preimeter device? You should not have a default connector set with anonymous permission group. You should create a new connector and lock it down via IP address.

So you have a misconfiguration somewhere.

Will.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lappladminAuthor Commented:
Thanks for the help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.